LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Using USRP 2974 on Labview NXG 5.1

Hello,

 

I am running the "USRP-2974 single-streaming" example in Labview NXG using a USRP 2974. Now I can connect to the USRP correctly. But when I run the "Tx streaming (Host)", I got an error that the "version of Labview real-time image on the terminal is different to that on host". 

 

The real-time image I installed on USRP 2974 is 

 

https://www.ni.com/en-us/support/downloads/software-products/download.labview-communications-real-ti...

 

Version 4.0. It is already the latest version. I am using Labview NXG 5.1 and all drivers/add-ons are the latest. 

 

Anyone meet the same problem before? Thanks for any help. 

 

0 Kudos
Message 1 of 4
(1,255 Views)

Not sure about your problem, but did you know that NXG is an end of life product, and that 5.1 is the last version?  You might want to re-think using NXG.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 2 of 4
(1,242 Views)

Thanks for your reply. Yes, it is tough. But USRP 2974 now only supports LabVIEW Communications System Design Suite 2.0 and later, not LabVIEW. I have to use it. 

0 Kudos
Message 3 of 4
(1,239 Views)

Hi,

 

I think I had a similar problem. The starting guide just asks us to download everything with the latest version. However, there is a compatible problem. I'll show my whole process to solve this error.

 

Step 1: Update your Real-Time Image to the latest version, which is 4.0 for now. Download the latest version of Real-time Image for USRP 2974.

 

Step 2: Install the Image on USRP 2974 follow the instruction. Find the title "Installing LabVIEW Communications Real-Time Image" to follow all steps.

 

Step 3: Download the compatible version of LabVIEW Communications System Design Suite (Labview NXG) on your host. (Based on another NI solution related to a similar issue, I know that the version of LabVIEW Communications on your host has to be compatible with the version of the LabVIEW Communications Real-Time on your USRP 2974. For example, if you are using LabVIEW Communications version 4.0 on your host PC please make sure that your USRP 2974 has installed LabVIEW Communications Real-Time 4.0.) https://knowledge.ni.com/KnowledgeArticleDetails?id=kA03q000000x2PpCAI&l=en-US 

 

Additional Information: LabVIEW Communications 5.0 cannot be used with USRP 2974 because LabVIEW Communications Real-Time Target Image only supports up to version 4.0.

 

Step 4: Download the NI-USRP driver. (I find a comment from NI that says there is the specific NI-USRP version for specific LabVIEW NXG or LabVIEW Communications System Design Suite, but based on my experiment, the latest version of NI-USRP will be fine.)

 

Hope this can help! I solved this error by following all steps I list. Welcome to any updates and thoughts on this problem!

0 Kudos
Message 4 of 4
(1,160 Views)