LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Using Legacy DAQ with newer version of LabVIEW?

I am using LV 8.3 to try to maintain an app which was created with LV 7.1. 

 

I chose to install legacy drivers when installing 8.3 but when loading I am getting errors stating that AIO Read and many other VIs/libraries can not be loaded.  "lvdaq.dll" was the most common one that I saw.

 

Is this DLL on the LV driver disks?

 

0 Kudos
Message 1 of 7
(2,575 Views)

This is not a problem at all. I have some old daq516 PCMCIA card. They need nidaq 6.9.3. But this is not a problem. I am running Labview 8.xx. Just find out which nidaq version you need and install to to your current labview version.

Read this first http://digital.ni.com/public.nsf/websearch/F185E098C7EC5A3486256D2E00691BB2?OpenDocument

Message Edited by t06afre on 03-03-2009 10:45 AM


Besides which, my opinion is that Express VIs Carthage must be destroyed deleted
(Sorry no Labview "brag list" so far)
0 Kudos
Message 2 of 7
(2,567 Views)

Okay.  I still have the old hard drives and installs from the previous setup.

 

Can I determine which version of the drivers was installed through MAX? 

 

 

0 Kudos
Message 3 of 7
(2,548 Views)

When I check the NI-DAQ under the start menu, I see NI-DAQ 7.0.  This is for the old system which functioned properly.

 

The file in the link references 6.9.3.  It also mentions "for 7.x and later..." 

 

I selected "7.1 support" when installing the drivers so I'm not sure what might be missing.

 

 

0 Kudos
Message 4 of 7
(2,542 Views)

LV 8.3? There is no LV 8.3. Do you mean 8.2?

 

As far as seeing what you have installed from MAX, this can be seen by expanding My System -> Software. Click on the software component, and the right-hand pane will give you the version. What you're looking for is "Traditional DAQ".

0 Kudos
Message 5 of 7
(2,541 Views)

davey31415 wrote:

 

I selected "7.1 support" when installing the drivers so I'm not sure what might be missing.


You need to install the support for the version of LabVIEW that you're actually using. In your case you want LabVIEW 8.x support. This installs the VIs and the palette for LabVIEW. 

0 Kudos
Message 6 of 7
(2,538 Views)

Yes I meant version 8.2.  

 

I had chosen that too.  Perhaps there's something else I'm missing?

 

Is lvdaq.dll specific to a certain version of labview or drivers?

 

Message Edited by davey31415 on 03-03-2009 05:40 PM
0 Kudos
Message 7 of 7
(2,535 Views)