LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading and Deployment

We have site licensed LabVIEW and many of our Physics labs have experiments that use simple DAQ/Control using USB/PCIe 6xxx (multi channel analog/digital I/O and counters). The TA who installed the intial software (2013) and helped building VI's graduated and left and our attempt to upgrade LabVIEW to 2015, broke experiments. We could restore the old version but would prefer staying uptodate.

 

What is the minimal/easiest way to deploy identical LabVIEW/Drivers/Apps/VIs environment on multiple Windows-7 64-bit machines? We have a set of working VIs on a thumb drive and we would like to have identical software on all PCs so that any PC can be used with any experiment with appropriate VI/adapter. Ideally, we would like to setup one reference PC with all the required LabVIEW s/w and deploy the image on all others.

 

I hope some of you have already done this. I am a non-expert in LabVIEW and any pointer will be appreciated.

 

Thanks,
Vinod

0 Kudos
Message 1 of 12
(3,827 Views)

I think LabVIEW 2013 is recent enough that the students in the lab will feel familiar with LabVIEW, even if they go work somewhere that is using LabVIEW 2015. Upgrading NI software often makes old programs not work, and you should budget about 4 or 5x more time then you think you will need to upgrade the computers.

0 Kudos
Message 2 of 12
(3,804 Views)

Gregoryj,

 

That is quite discouraging comment about LabVIEW, may be that is the realitySmiley Sad  Thanks for sharing your experience.

 

I have see our old TA strugging to make the whole thing work. Which makes it even more desirable to have a deployment plan in place, not sure in NI already has one.

 

Vinod

 

0 Kudos
Message 3 of 12
(3,795 Views)

Heh, well I spent the better part of last week trying to upgrade (and then downgrade when I could not install vision development for 2015), and it was difficult going both ways. Perhaps someone less jaded by a recent bad experience will be able to offer some advice 🙂

0 Kudos
Message 4 of 12
(3,790 Views)

Just got the 2015 "kit" (a USB Flash Drive), am trying a 2015 Installation on Windows 7.  Have already gotten the error message about not having authority to install NI Discovery Service (I think that's the name) -- a message that's familiar (I'm pretty sure I've seen this every six months or so when I do an Install), but don't remember the fix.  Anyway, this time NI let me continue with the installation instead of rolling back everything (after a half-hour).

 

I recently met a long-time (almost 30 years!) LabVIEW User who uses only Macs.  He claims he can install/update a new version of LabVIEW on his Mac in 5 minutes!  Wow.

 

I wonder if I can build my own USB drive (or an ISO Image of one) for older versions.  Would make doing a Repair much simpler since you wouldn't have to "guess" which DVD to put in the drive ...

 

Bob (maybe Installation on Windows 10 will be "nicer") Schor

0 Kudos
Message 5 of 12
(3,780 Views)

Good news!  After trying to do an Install from the USB Key (letting its Autorun code auto-run), I got three things (LabVIEW, LabVIEW RT, Vision) pop up errors involving the NI Discovery Service.  Unlike previous installs (2014 and earlier), I could ignore the error and let the install proceed.  When it finished, I got a note saying three things didn't install properly.

 

So I rebooted.  This time, I opened the USB file system, ran "Startup" as Administrator, and set it up to reinstall the same VIs.  This time, it took about 2 minutes (I think it just fixed the Discovery Service), it Activated, and now seems to be running.  I have not yet installed DAQmx and the Drivers ...

 

Bob Schor

0 Kudos
Message 6 of 12
(3,759 Views)

Vinod,

 

What exactly is broken after upgrading and what have you installed so far besides LabVIEW?

Matt J | National Instruments | CLA
0 Kudos
Message 7 of 12
(3,735 Views)

Matt,

 

The DAQ modules were no longer functioning.

 

Vinod

0 Kudos
Message 8 of 12
(3,723 Views)

And you did install the new drivers that support LabVIEW 2015?  

0 Kudos
Message 9 of 12
(3,712 Views)

"Old" doesn't generally mean two years.  Old means "I haven't updated this program since 2008.  I realize a lot has changed in the computing world since then but why did the drivers change during that time?"  That often happens.

 

Upgrading from 2013 to 2015 means you probably didn't install the new DAQmx drivers for 2015.  When a new version comes out, there is support added to the driver to install with the new version of LabVIEW. 

0 Kudos
Message 10 of 12
(3,694 Views)