LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Undead LabView

Solved!
Go to solution

LabView.png

 

Hi.  I have a very old and dear set of LabView 7.1 Professional Development System installation disks.  The installation is hopelessly corrupted somehow.  I cannot remove it, repair it or reinstall it.  And it won't let me uninstall anything else in Windows 8.1.

 

On Windows startup, NI LabView Run-Time Engine 7.1 reports "Please wait while Windows configures NI LabVIEW Run-Time Engine 7.1", which just hangs indefinitely, forcing me to use Task Manager to close it.

 

If in Windows I go to Programs and Features and attempt to uninstall "NI LabVIEW Run-Time Engine 6.1", it just reports "Another program is being installed. Please wait until that installation is complete, and then try installing this software again."

 

If instead, I try to uninstall "National Instruments Software", NI Package Manager comes up, shows a list of 23 installed NI components. None of them can be apparently be removed in PM's window. One and only one entry is greyed out (NI Package Manager v19.5.0).  For example, if I select to remove "'LabVIEW Runtime (32-bit), that fails with:  NI Package Manager.  We found a problem with your request.  An error occurred while removing a package d0cc0ecd-cde1-4f7b-bea9-b86970da391c (19.0.0).  Additional error information.  An error occurred while uninstalling the MSI at '-IsCore-install.msi'.  My only option is to Cancel. I can press Help, which will bring up a web page titled: "Package Manager User Manual - Troubleshooting Problems with Installing, Updating, Repairing, or Removing NI Software", but nothing there is helpful.

If I try to just reinstall from installation disks, I get, "Installer Errors.  error 1618 while trying to install NI LabView development system v7.1 from install disk.  Repairing Products...
  Currently Repairing NI Instrument IO Assistant for LabView 7.1."  But NI Package Manager hangs forever while "Canceling Transaction".

 

I just want to remove LabView and all its associated products completely and reinstall from scratch.  Any ideas on what to do with my dear old battle axe?

Download All
0 Kudos
Message 1 of 13
(552 Views)

Uh-oh, NIPM + LV 7.1 = recipe for disaster.  I wouldn't even know how to fix that.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
Message 2 of 13
(486 Views)
Hi

 

The situation looks very bad.

 

The Package Manager was first used as the only installation option in 2019. But it could be installed since 2017. And it tries to manage older LabVIEW versions than 2017. Whether it is really good at it is not really known. NI has never stated how far back it can sensible manage. Nor can you decide at a version it should stop. The best idea would probably have been to avoid installing the Package Manager for this old LabVIEW version.

 

Users of the first versions of Package Manager weren't all very happy. Search this forum. There were problems.

 

Even with never versions of LabVIEW you might experience that the repair functionality is not 100% fail-proof. I have. So you probably look into a complete re-install, unless you have a functional backup.

 

The only chance I see for a recovery out of this situation is upgrading the Package Manager. Install the newest. Maybe NI has fixed something since 19.5.

 

Regards


Message 3 of 13
(480 Views)
Solution
Accepted by topic author tedj121

When NIPM first came out (and, more or less, every year since then), installing LabVIEW became more "interesting" (and almost equally frustrating).  There is, I believe, a "safe way" to remove all NI Software from your PC (or, at least, from "Windows" knowledge of it, though some of the files might still be present and "just taking up disk space").

 

I always use (and recommend) Control Panel for uninstalling LabVIEW.  This is, of course, part of "old Windows", but is still present in Windows 10 (don't know about Windows 11 ...) -- click the Search box in the lower left and type "Control Panel".  Open "Programs and Features", which brings you to the "Uninstaller".  There should be one or two "NI" (or "National Instruments") entries, one for NI Software and (possibly) one for NI Package Manager.

 

Choose the one that is not Package Manager.  Click it.  It might bring up NIPM to do some of the "uninstallation".  Select "everything" (the checkbox above all the other checkboxes on the left -- try to make sure that it's showing you "everything") -- it won't let you select NIPM itself.  Go ahead and let it uninstall everything.  Reboot, repeat (to make sure you got everything).  If you get it down to only having NIPM showing, then select NIPM (which, now, you should be able to do) and tell it you mean to uninstall it.  When you reboot, do this one more time, which might find other NI Software that "predates" NIPM.  Get rid of them, too.

 

Now you should be able to do an installation of LabVIEW 7.1.  I recall that when Windows 7 was released, LabVIEW 7.0 was not supposed to be installable on it.  I managed to do so, but don't remember right now how I did it.  I might have some notes lying around ...

 

One final word -- if you do try to install LabVIEW 7.1, do not install NIPM first.  Let the installer that came with LabVIEW 7.1 do its work for you.

 

Bob Schor

Message 4 of 13
(412 Views)

I WAS able to completely remove (after much thrashing about) NIPM, LabVIEW and all of its components entirely from my machine the right way (i.e. not hacking the registry or similar) through the normal uninstall processes, more or less as Bob describes - a combination of Windows uninstall following an NIPM UPGRADE of all components, which appears to have been the key.  At that point, I reinstalled from the original installation disks.  A full default reinstall (well, everything except IEEE 388.2), which only asked for the first two disks from:


Disk: LabVIEW 7.1 Professional Development System
Disks: LabVIEW 7.1 NI Device Drivers CD 1 of 2 (and 2 of 2)
Disk: Developer Suite Add-on Software CD
Disk: IVI Driver Toolset Version 1.1
and Disk: Measurement Studio Version 7.0


I, of course, rebooted following the successful installation.  No Windows startup errors, no problems.  LabVIEW itself barring other issues has always worked then and now just fine.  I'm still using Windows 8.1, by the way.  BUT, I much desired the additional install of the (NI-IMAQ and) IMAQ-Vision for the image-oriented functionality.  So, I then proceeded to install from two more original installation disks in my possession:


Disk: IMAQ Vision Assistant for LabVIEW Version 7.1
Disk: Vision Builder For Automated Inspection Version 2.6.1


Note that only the first disk is asked for and the install never asks for the second disk, which I assume I don't need, I not needing to do automated inspection. That's where the problems arise.  An error pops up during that install.  As I recall, it has to do with LabVIEW Run-time 7.1 not being found and being asked for, although it is clearly present and installed, as evident in NI-PM's installed list as seen in my original post.  I continue the (partial) installation through and reboot again.  Now, both LabVIEW and IMAQ Vision are installed and I can draw out a VI without errors.

 

The only problems that remain are the previously reported Windows startup hang, which I cancel with Windows Task Manager by deleting the running VIPM:

 

On Windows Start.png  

 

And the much more severe problem of not being able to uninstall ANYTHING in Windows:

 

Nothing uninstalls.png

 

The next challenge after that being the NI Activation Wizard, which is evidently required on first use of IMAQ-Vision:

 

NI Activation Wizard.png

 

 

0 Kudos
Message 5 of 13
(376 Views)

I actually have the luxury of starting from either the point described in my last message OR starting from the point of National Instruments EVERYTHING uninstalled and ready for a clean guided install, if anyone would like to offer anything further in how to have my cake as I want it.  Because I made a clone just after I finally got NatInst uninstalled.

 

I'd like to thank everyone who has participated.  Although LabVIEW (et al) has grown big and fat by now, my heart will always belong to the beauty, efficiency and usefulness of LabVIEW, which I've always thought something of a revolution in programming and before its time.  And the community willing to help fools like me a group that cares.  Thanks all.

0 Kudos
Message 6 of 13
(360 Views)

LV 7.1 will always hold a special place in my heart.  It simply worked as advertised.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
Message 7 of 13
(326 Views)

I just finished to install a 7.1 program on a Win10 industrial computer and it works perfectly! (no drivers other than serial VISA)

Paolo
-------------------
LV 7.1, 2011, 2017, 2019, 2021
0 Kudos
Message 8 of 13
(266 Views)

@pincpanter wrote:

I just finished to install a 7.1 program on a Win10 industrial computer and it works perfectly! (no drivers other than serial VISA)


Whew!  Glad to hear that.  We were running LabVIEW 7 (not 7.1), and I remember "there was a trick", but I'm not certain I wrote it down ...

 

Bob Schor

0 Kudos
Message 9 of 13
(241 Views)

Looks like NI will no longer give me an activation for NI IMAQ / IMAQ Vision.  So, I can't use use it anyway.  So, just a clean LabVIEW install from my hard drive that I was somehow (Act of God??  No, really.) able to entirely remove all things NI from is clearly all that I can use anyway.  The image stuff in default LabVIEW should do.  I can 'hack' the rest.  Cheers.

0 Kudos
Message 10 of 13
(233 Views)