Showing results for 
Search instead for 
Did you mean: 

USB-serial not found by NI-VISA

Hello Bill,


I couldn't find your link (they were blocked by my company), is there any way to find them? Thanks!


I have the same problem, and it will be fixed if I unplug USB and replug in USB again.(re-install the usb driver I guess) But it really bugs me a lot. I tried to use devcon to remove the usb port then rescan it, but it doesn't work. I'm using windows 7.



0 Kudos
Message 21 of 23

I'll keep an eye on this thread, since I'm seeing a similar situation.  I'm also using an FTDI chip and communicating with it via a USB-to-serial converter under Windows 7.  I made a small program that looks for the COM port the USB device is claiming, sends out a quick VISA write and if it sees the response with a VISA read it knows the USB port on the device is good.  It worked fine for about a week or so, but now all of a sudden I'm finding when I plug in the USB cable the "USB to serial" driver will pop up, as it should, but Windows will claim the device is a USB mouse and the cursor will go nuts and the device won't communicate anymore.

Amateur programmer for over 10 years!
0 Kudos
Message 22 of 23

One of my colleague solved this problem by using hardware: disconnect the USB power supply and reconnect it again, so window think it's a new one, so it started install the usb device driver again, and then VISA found it.

0 Kudos
Message 23 of 23