LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Triggering to Initiate Digital Output on USB-6003

Solved!
Go to solution

Hello all,

 

I am trying to trigger a digital output pin based off one of the two available PFI pins on the 6003. The goal is to basically have the trigger input mirrored on the output (with some variable amount of delay in between for later purposes) so we can record the exact moment the trigger happened, and then control a different piece of hardware from the output.

 

For some reason, I cannot get triggering to work. I've tried both digital triggering for digital output AND analog output and it does not work.

 

TriggeredOutHard.vi is my main attempt and what I would assume would work. There are no errors when it runs, but the output does not change at all.

 

I can do it in software - as in, read and write that value back out in the same while-loop - but the timing is sporadic between the triggers falling edge and the outputs.

 

I'm new to LabVIEW so, I'm sure there is some error I am just not seeing. Any help is appreciated!

0 Kudos
Message 1 of 4
(2,703 Views)
Solution
Accepted by topic author JoshuaBRussell

I have a USB-6002 (a slightly slower version of the USB-6003) and wanted to do the same thing, trigger a Digital Output (pulse) on receipt of a PFI Rising Edge.

 

Sad to say, the manuals clearly state you cannot trigger the Digital Output lines with a PFI Input.

 

So I "cheated".  I created a Waveform that consisted of a 10 ms Analog Signal that was 5v at time 0 and 0v the rest of the time.  If I played this Signal through an Analog Out port at 1kHz, I would have a 1 ms pulse at time 0.  And the AO port can be triggered by a PFI pulse.  Indeed, if you want a pulse train, you can define it as an Analog waveform taking on "digital" values (0 or 5v) and play it through an AO port.

 

This works just fine.

 

Bob Schor

Message 2 of 4
(2,680 Views)

Thanks for the reply! I never did see that in the manual (I assumed I missed it), but from what I read, I did get that impression.

 

I'm new to LavVIEW so getting the Analog out to trigger is not working for me. I'll upload what I have currently. With that being said, would you mind posting an example of what you got to work?

 

I'd appreciate it.

0 Kudos
Message 3 of 4
(2,655 Views)

Scratch that. I was able to get it working. There was an example ("Voltage-FiniteOuput.vi") that looked like it was exactly what I wanted, but would not trigger/produce on output. So I proceeded to create it from scratch, and then it worked.

 

First I used a waveform, then switched over to using an 1D-array for the samples.

 

The file is below for those who wish to reference it.

0 Kudos
Message 4 of 4
(2,649 Views)