Showing results for 
Search instead for 
Did you mean: 

Timin Error LabVIEW with Scope MDO34

Hello everyone!
I made a code to control an oscilloscope model MDO34 from Tecktronics.
When I run the code after the first reading I is okey, but the next iterations get a time error, I tried with Stall Data Flow,Wait(ms),Wait Until Next ms Multiple and with all three I still get an error.
Any recommendations or comments about my code?

I attach images and the VI




0 Kudos
Message 1 of 5

HIghlight execution and Use the Single Stepping to identify when does the error occurs. 

From the message, It looks like the instrument stop responding after the first iteration. 


You need to findout if the error occorred in the last operation of the 1st iteration or in the subesquent operations. You may need to investiagate if you are not missing any commands in between each iteration. 



0 Kudos
Message 2 of 5

The error its comes from the Single Waveform SubVI



0 Kudos
Message 3 of 5

Here is the error



0 Kudos
Message 4 of 5

Did it occured on the first iteration ? 

Dig deeper into that VI and investigate at what point the error occurred. Use start single stepping, and you will be taken to the subvis and verify where exactly the error occurred. 




0 Kudos
Message 5 of 5