LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

The specified action could not be completed

I use LabVIEW SignalExpress 2010 on a Windows XP 32bit PC.

My Data Acquisition Device is a cDAQ-9172 with a NI 9205 ans NI 9219.

 

In SignalExpress I get regularly the Error message: "The specified action could not be completed". When I click on OK the error message reappears immediately and endless. After this message appears, the only thing I can do, is to kill SignalExpress in the Task Manager. Usually, this message doesn't appear when I am working with SignalExpress, but when it is just running in the background (either when it is capturing data or when it is just inactive). But thank god, the measurements continue. But I have to stop the measurement by killing SignalExpress in the Taskmanager.

 

In the eventviewer of Windows, when I start SignalExpress, I always get the error "LabVIEW information:  Error: 400 "Bad Request" for "deletetree", file "": Unsupported protocol       ."

I don't know if this error has something to do with the other one.

 

Does anybody can help me to solve this problem?

 

Thanks

0 Kudos
Message 1 of 6
(1,933 Views)

I just observed, that the message "The specified action could not be completed" always appears, when I lock the screen in Windows. But I think it happened also already in other cases, but I couldn't reproduce it.

0 Kudos
Message 2 of 6
(1,925 Views)

Hey Laurent0,

 

Is there anything that you can do to reproduce that error message reliably besides locking your screen? What sort of task is running when SignalExpress gives you these error messages? SignalExpress almost always throws errors if it is running a measurement when you lock the screen or the screensaver comes up. This is due to the way that Windows handles power saving. You might be able to fix these errors by changing your power profile in Windows to Maximum Performance and disabling your screensaver. Hope that helps!

John B.
Embedded Networks R&D
National Instruments
Certified LabVIEW Developer
0 Kudos
Message 3 of 6
(1,907 Views)

Hello

 

In the last days I tried to observe when exactly the problem is occurring. I disabled the screensaver and never locked the screen.

The error message still occurred several times, but not in a reproducible way:

Once when I was working in Excel and Signalexpress was just opened in the background without running.

Once when I was renaming a log in Signalexpress and Signalexpress was not running

Several times during the acquisition of data. It happened not immediately after the start of the data acquisition but maybe a quarter of an hour later.

 

The error is not really reproducible, but always appears when I use Signalexpress for a long time.

 

Regards

 

0 Kudos
Message 4 of 6
(1,885 Views)

Try repairing your installation of SignalExpress, see if that fixes the problem. Make sure that your anti-virus software is disabled when you repair the installation. Sometimes security software interferes with the installation of certain components, and may have caused the issues you are seeing. Let me know if that works for you.

John B.
Embedded Networks R&D
National Instruments
Certified LabVIEW Developer
0 Kudos
Message 5 of 6
(1,872 Views)

Repairing the installation didn't fix the problem.

 

But I found out that the problem is only occurring when I have opened the operator interface in SignalExpress. But I don't really need the operator interface, so I closed it, and since then, I had no problem any more.

0 Kudos
Message 6 of 6
(1,817 Views)