LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

The VIServer doesn't work when importing/exporting complicated and many input/output VI.

My VI server and client works fine when I importing and exporting uncomplicated VI. When I import/export many input/output and complicated VI, that complicated VI doesn't give any output. I don't get any error in the error message either (it said "No error"). And my client program looks like it gets hang - I can't stop the program. In this case, I have to shut down the server program then I can stop the client program. Is there any way that we can solve this problem?
0 Kudos
Message 1 of 2
(1,772 Views)
It's difficult to determine the cause of the problem from your description. Here are a few suggestions:

1. Bundle the inputs to your complicated VI's into a cluster. Do the same with the outputs. You will technically then have only one input and output. This will keep you connector pane a lot cleaner and less confusing.

2. Have Highlight Execution turned on in your complicated VIs. This will allow you see the portions of your complicated VIs that might be slowing them down.

3. Run your complicated VI's without VI Server and with a set of input data that allows your VI to run quickly. Then, using VI Server, pass this same input data to your complicated VI's. This will allow you to determine if there is a problem with the way you are calling y
our complicated VI's.

Chris_Mitchell
Product Development Engineer
Certified LabVIEW Architect

0 Kudos
Message 2 of 2
(1,772 Views)