Showing results for 
Search instead for 
Did you mean: 

Test Stand Labview API: How can I deploy a Test Stand Sequence whose relative path is too long?



I am using Test Stand Labview API with DQMH,

I have created DQMH modules in Labview and my Test Sequence consist of Request VIs to the DQMH modules. When I create an Exe to be deployed in a different system I am facing the following problems:


1. The Test Stand Sequence is Unable to locate the VIs since the source is not present on the System where the Exe is Deployed.


I have tried using the Test Stand Deployment Utility to create an Image of the Test Stand Sequence. But my observation is the Test Stand Deployment Utility Auto-detects Dependencies and then uses relative paths to the Test Sequence and Sub-sequence files.


2. The relative path in the Image is too long and the Test Stand is unable to locate the files in Image too.


Is there a better way to do this? I am missing something?


Any help is appreciated.



Linus Koli 

0 Kudos
Message 1 of 4

I've had this problem in the past with TestStand at a customer site.
The simplest solution was just to map a drive letter to cut the path length down.
(customer had ridiculous path lengths., we mapped  55 chars off that path name and everything worked nicely in the newly created "W:\" drive 😉)
Would suggest you create a path length check tool and limit you filenames and folder depths for TestStand though - it can be a killer.
I can't remember (I think I last did is in about 2014 or something like that) - I think the max path length for TestStand is 125 chars Windows can go much higher.


CLD; LabVIEW since 8.0, Currently have LabVIEW 2015 SP1, 2018SP1 & 2020 installed
0 Kudos
Message 2 of 4

Thank you James,


I do not entirely understand the part about mapping a drive letter.

Can you please elaborate or provide an example or article to which I can refer?


Thank you again.


-Linus Koli

0 Kudos
Message 3 of 4

Hi Linus

on windows you would be looking at the subst command:
subst | Microsoft Docs



CLD; LabVIEW since 8.0, Currently have LabVIEW 2015 SP1, 2018SP1 & 2020 installed
Message 4 of 4