Showing results for 
Search instead for 
Did you mean: 

Target-scoped FIFOs/ missing methods error

Go to solution

In my project, there are two FPGA vi's and 4 pairs (read and write) of target-scoped FIFOs that are used to pass data between the two vi's.


One FPGA vi (named  writes data that it obtains from an RS232 port to READ FIFOs; it also reads data from WRITE FIFOs and passes it to  ports.

The second FPGA vi (named griffin writes data to WRITE FIFOs and reads data from READ FIFOs. There are no other vi's in the project.


When I try to run either of the vi's, I get an error about missing methods for FIFOs. For example, when I run, I get an error that Read FIFOs need to have the read method (see image named rs232 side) and that Write FIFOs need to have the write metod presend on the block diagram in that vi. However, these "missing" methods are present in the second FPGA (as I described above). The same type of an error appears when I run the


Why can't the compiler see that I have all  methods; however, they are in 2 separate vi's? How can I avoid this error?

Download All
0 Kudos
Message 1 of 5

Can this be due to problems in the hierarchy ?

0 Kudos
Message 2 of 5

Are both of these VIs called from the same top-level VI? If not, that error makes sense, since you can run only one top-level VI on the FPGA at a time.

0 Kudos
Message 3 of 5

Why can't one of the vi's be the top level vi? 

0 Kudos
Message 4 of 5
Accepted by topic author SophieJS

@SophieJS wrote:

Why can't one of the vi's be the top level vi? 

That would be fine too, so long as one of them calls the other. I didn't see that in your screenshot, though.

0 Kudos
Message 5 of 5