Showing results for 
Search instead for 
Did you mean: 

Stepper Motor Example

Hi guys,

I am trying to rotate my stage with the Big Easy Stepper Motor Driver and Arduino Uno Board. The arduino was not performing in my larger program, so I wanted to make sure I could move it with the Stepper Motor Example. However I continue to get errors (5002 and 5003). I am fairly new to Arduino and have never used it with LabVIEW, so I attached the setting for the pinning that was done by another student. I believe I am entering the incorrect Stepper # and corresponding Stepper Pins array. I don't believe the issue is the USB connection, but could be wrong. Thank you. 

0 Kudos
Message 1 of 3

Update: The pins connected are 2 and 3. I am selecting that as my pins with stepper # set at 2, correspondingly. I am now getting this error (-1073807298) in the program. I tried a build from a youtube video I found, so I will link that new VI down below. I also ran the port the Arduino UNO is connected to in computer (COM5 as my computer says) and get the same error when I run it through a property node. Please let me know if there are any ways to fix this and what may be the cause of such a problem.

0 Kudos
Message 2 of 3

Check the Link below, It may be useful for your Error 5003 

Palanivel Thiruvenkadam,
CertifiedLabVIEWArchitect|| CertifiedTestStandDeveloper
0 Kudos
Message 3 of 3