Showing results for 
Search instead for 
Did you mean: 

SMTP Email Error 54

Hi all, 


Why does SMTP Email vi does NOT work? I searched the forums but could not find the answer. I am using LabVIEW 11 development suite on Windows 7.


Here is what I tried:


1. I put in the IP address of our SMTP server obtained from our IT department - didn't work (btw, the format for this IP address is xx.x.xx.xx

2. I put in (where obviously mycompany is the name of my company - again this info was provided by our IT department) - didn't work

3. I put in my personal gmail address, and - didn't work


In each case I get Error 54. Why is this happening? Are there certain LabVIEW settings that I am not setting correctly? The error message says to check if I have DSN properly configured.

Does this mean that I need to setup something in Win7 that allows LabVIEW to communicate with the outside world (ie, send an email)?






0 Kudos
Message 1 of 32

The error message suggests that the IP can not be accessed from your computer. Have you tried to ping it from a dos prompt?


Open the email example from the example finder and try using a gamail address with the following parameters (everything unmentioned is obvious):


email: your email add


port: 587

Use TLS: true


I use these params everyday from labview and never had an issue with them. If it works for you then your company server params are wrong. If it doesnt work for you then you have a firewall or a general network issue.


Message 2 of 32



Before posting my message, I did ping the IP address from the DOSC command and my PC does send and receive data.

My computer is on my company's network and I am trying to email co-workers (send automatic emails with data updates). 

Firewall should not be an issue.


I opened up the EMAIL examle (one when a certain temp > limit, then it sends email), but didn't see anywhere to enter the PORT.

BTW, for all EMAIL VIs, I don't see any of them showing a PORT connector. I see email, server, subject, etc, but not PORT.

0 Kudos
Message 3 of 32

try to enter the smtp address like this:

0 Kudos
Message 4 of 32



I did try that to no avail. In fact, since I am using my work computer I put in my personal gmail address (as recipient), I put for server, and run the VI, got the same error.

It seems to me that LabVIEW isn't configured to access anything outside of my work PC. 


I am trying to find materials on how exactly these VIs access the network. My thought process is that LabVIEW is sitting on my PC as an application, and the operating system (Windows firewall and my anti-virus program)

controls which applications can access the network (local or outside of our company). So maybe I need to configure Windows somehow to allow LabVIEW to access the network, similar to how one configures an ODBC Data Source to allow certain applications (like LabVIEW) to access a local or network database. But again, isn't it true the a firewall would normally prevent stuff from coming into the computer, and not preventing stuff from accessing outside. 


Is there a way to test the IP from a blank VI (similar to ping from a windows command line)? Also, the sever IP provided by our IT department has the form xx.x.xx.xx (not Does this make a difference?

0 Kudos
Message 5 of 32

I suggest to forget about your company environment for now. There is a more iminent problem which is that you can not even able to send emails via a known good service. So I would concentrate on resolving the problem with gmail, it may resolve your problem with your company server immediately.


The IP address as we see it is a decimal representation of four hexadecimal numbers. It doesnt matter if you write "1" instead of "001", its still gonna be 0x01, so dont worry about that. You can use the trailing zeros if that makes you more comfortable.


Firewalls also can block suspiciuos programs running on your computer. You must check, maybe LabVIEW is blocked at this moment. Google it, or just click to the link, I did it for you. (




Attach your VI let me check it (the VI you want to use for gmail, so the LV2011 example). I have LV 2013, I believe the example is changed for this version.)


0 Kudos
Message 6 of 32



You can try the following: my email: (server = or


By the way, I tried the HTTPClient Get VI and was able to read the content of Therefore, I conclude that my LabVIEW is at least able to access the internet.








0 Kudos
Message 7 of 32

attach your VI and not a screenshot.

0 Kudos
Message 8 of 32

Here you go:



0 Kudos
Message 9 of 32

I dont know what is this VI and I dont know what do you expect this to do. This VI is not the part of LV 2013, but how an earth this VI supposed to send an email without a password field? As I said open the example finder and try sending a mail from a gmail address. I know that it works. I have no experience at all with the server you use, so do not add another variable into the equation.


BTW the VI you sent produces an error 54 to me as well.

0 Kudos
Message 10 of 32