LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Pulse Generation from PCI-6229 through BNC-2110

I am trying to control a hobby servo motor SG90 with a  BNC-2110 card connected to PCI-6229. When I try to test the configuration with test panels from NI Max, I do not get any response. I connect the signal cable of motor to CTR0 OUT on the BNC-2110 card and use an external power supply with a common ground to card. My test parameters are;

channel: CTR0

mode: pulse train generation

pulse terminal: /Dev1/PFI12

Frequency: 50

Duty Circle: 5-10

 

I tried to test the outputs with an oscilloscope, I do not get any response. Also, I found a thing that I do not understand; it seems to be that CTR0 OUT connected to digital P0.28 of PCI-6229 and CTR1 OUT connected to digital P0.29. Then if this is the case, where is the CTR0 and CTR1 in the BNC-2110?

 

I could not find my way through this, any help?

 

ps. I think, I send the message to wrong discussion board, sorry for it!

0 Kudos
Message 1 of 6
(1,521 Views)

Hi Altug,

 

Since you set the pulse terminal (pulse output terminal I guess?) to PFI12, this is where youre pulses should be generated. You can set it to any PFI you want. The CTR0OUT-Connectors are just the default PFIs the counters use if you don't specify a PFI-Pin.

 

Is there a signal on PFI12?

 

Best,
Jan Göbel

Staff Applications Engineer

National Instruments

0 Kudos
Message 2 of 6
(1,492 Views)

Dear JGoebel,

 

Thank you for your message. Unfortunately, I could not change the pulse terminal(it is grayed out) and there is no output for PFI12 on the BNC-2110 board as it can be seen in this picture; http://gzwg.blogspot.com/search/label/NI%20BNC-2110 . In the installation guide( http://www.ni.com/pdf/manuals/372121f.pdf), it says the PFI12 is directed to CTR0 OUT, but in my case, this simply is not true. As I said before, I can not get any signals from CTR0 OUT BNC terminal, beside if I test PFI28 than I get a test signal from this terminal but not a pulse generation.

 

Best,

Altug

0 Kudos
Message 3 of 6
(1,483 Views)

Hi Altug,

 

that is weird, have you got the possibility to connect a small probe (thin wire) to the output of the device without using the BNC-Box? You can find the pinout in the Measurement and Automation Explorer.

 

Are you trying to output this Signal from LabVIEW? Are you using the DAQ Assistant or the low-level DAQmx-Functions?

 

Best,

Jan

Message 4 of 6
(1,480 Views)

Dear Jan,

 

I find the solution. BNC-2110 is not the only accessory that is connected to PCI-6229; there is also SCB-68. If you take a look at this page; http://digital.ni.com/public.nsf/allkb/5B4D23831C6A8C2D86257354004DE008 you can see that, the connections changes with different connector blocks. So apparently BNC-2110 is connected to block 1 and SCB-68 connected to block 0. I simply connected motor to 2nd pin, which is connected PFI12 in PCI-6229(reference: http://digital.ni.com/public.nsf/allkb/08F2502FB569F38286257D8D0017838E ) and now it works, both with NI MAX test panel and with LabVIEW application!

 

Best,

Altug

0 Kudos
Message 5 of 6
(1,476 Views)

Hi Altug,

 

glad to hear that it works now, I didnt thought about the two ports of the board, but it makes perfect sense.

 

Let me know if you have further questions, otherwise I wish all the best for your application.

 

Best,
Jan Göbel

Message 6 of 6
(1,459 Views)