LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with simultaneous AI and DO tasks: Error -89137

Solved!
Go to solution

I have a PXI system with two X-series PXIe-6345 modules. I have to create an AI Countinuous Sampling task, to acquire data from channels in these two modules, which runs fine. Then my application requires to to create a DO task and Counter task some time later, when the AI task is running. But I get the following Error:

Error -89137 occurred at Test_DO_Write chn.vi

Possible reason(s):

Specified route cannot be satisfied, because it requires resources that are currently in use by another route.

Property: RefClk.Src


Source Terminal: None

Required Resources in Use by
Task Name: _unnamedTask<53>
Source Device: PXI1Slot2
Source Terminal: PXIe_Clk100
Destination Device: PXI1Slot2
Destination Terminal: RefClockInternal

Task Name: _unnamedTask<51>

 

(unnamedTask<51> is DO task and _unnamedTask<53> is AI task in the above message)


Source Device: PXI1Slot2

 

I get this error whenever I try to create a new DO or Counter task in the same 6345 module, during an ongoing AI acquisition.It looks like the DO task is trying to access the Int.Ref.Clock line, to which a 100MHZ clock is already routed for the AI task. I tried to assign this 100MHZ clock, as Ref. clock for the DO task, using propery node. But it returns error indicating 'harware not supported;. 

I am also attaching a VI to explain this issue.

Arun Joy
Certified LabVIEW Architect
0 Kudos
Message 1 of 4
(2,621 Views)
Solution
Accepted by topic author ArunJ

The proble has been resolved. By setting the PXI 100MHZ backplane clock (PXIe_Clk100) as the reference clock for both AI and DO tasks, using DAQmx Timing property nodes "ReferenceClock.Source" and ReferenceClock.Rate", things are working properly.

Arun Joy
Certified LabVIEW Architect
Message 2 of 4
(2,562 Views)

Hello,
I am facing the same problem. I am creating DI and DO tasks, and giving them the same sample clock. But I tried your approach too but got the same error. Can you please explain in detail how you managed to get rid of the error?

 

Regards,
Lij

0 Kudos
Message 3 of 4
(2,394 Views)

Capture.PNG

Doing this solved my problem.

Arun Joy
Certified LabVIEW Architect
0 Kudos
Message 4 of 4
(2,337 Views)