LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

PN-Driver missing function ...:C in ...dll

Solved!
Go to solution

Good day everyone,

 

I have a problem to transferring a labview-project into a .exe with a dll from Siemens.

The .exe works fine on the computer where labview is installed. But when I transfer the .exe to another computer without a labview-software, the .exe does not work. The RT-Engine is installed on that computer.

 

I get the following errors:

Missing external function PNIO.dll:Stop:C in Main.vi

...

...

 

Thats the functions I'm using in my project.

 

How can I get this to work correctly?

 

Thanks for the help.

 

->LabVIEW Student 2016

->Windows 10

0 Kudos
Message 1 of 9
(421 Views)

Hi SCLer,

 

did you create an installer for your executable?

This should include the needed DLL(s) automatically…

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO
0 Kudos
Message 2 of 9
(415 Views)

Did you even install the Siemens Profinet driver on that other computer?

Rolf Kalbermatter
My Blog
0 Kudos
Message 3 of 9
(390 Views)

Did you install the Siemens Profinet driver on that other computer?

Rolf Kalbermatter
My Blog
0 Kudos
Message 4 of 9
(389 Views)

Good day,

 

I can not install the dll. They are just a few files to download.

Link: https://support.industry.siemens.com/cs/document/99684399/sinamics-g-s-profinet-connection-with-labv...

 

I think I know whats the problem might be. I have to install a redistriutabel and winpcap on the other computer. Tomorrow I have the chance for a test.

 

 

0 Kudos
Message 5 of 9
(371 Views)

I can't access that archive without a Siemens account. And I have no idea if that library simply accesses whatever Ethernet interface your computer has or if it requires additional hardware and/or drivers. In a true Siemens way I would expect it to somehow require some additional components to work at all, including a license manager or maybe a dongle.

Rolf Kalbermatter
My Blog
0 Kudos
Message 6 of 9
(325 Views)
Solution
Accepted by topic author SCLer

Good day,

 

I have solved the problem.

I tested it on another computer.

I started with the installation of the runtime-engine from labview. After the execution of the .exe, the program is still not running. Then I installed the redistributable with the VC_redist.exe. I started the .exe again and the program is still not running without errors. Then I installed winpcap with WinPcap_4_1_3.exe. After that, I tried it again. The program runs successfully.

 

Thanks to the repliers.

 

Regards...

0 Kudos
Message 7 of 9
(320 Views)

Hmm, seems that DLL doesn't use proprietary hardware then but directly accesses the ethernet interface through the winpcap driver to send its Profinet network frames. Makes kind of sense.

 

But note that WinPCap is abandonware: https://www.winpcap.org/.

It has several problems with the newer modern NDIS6 network drivers in Windows 7 and higher.

 

It's replacement nowadays is npcap, which can be installed in a compatibility mode to provide a WinPCap compatible driver interface.

Rolf Kalbermatter
My Blog
Message 8 of 9
(311 Views)

Good day,

 

thank you for your help.

You are right, npcap is the newer software.

 

Regards...

0 Kudos
Message 9 of 9
(296 Views)