LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Only toggle-buttons in LabView NXG Web Module 4.0?

Solved!
Go to solution

Hello!

 

I'm currently working with the new Web Module for LabView NXG an ran into the following problem. I've added a few simple buttons to my WebApp an they all behave like a toggle switch not like a "normal" switch. I've digged into the whole html/ java thing (still very new to me) to see that the buttons are indeed added as a jqx-toggle-button (see below) no matter what button behavior I select in LabView.

 

<jqx-toggle-button binding-info='{"accessMode": "readOnly", "dataItem": "dataItem_LoadFirmwareFile", "dco": 12, "isLatched": false, "prop": "value", "sync": false, "unplacedOrDisabled": true}' click-mode='press' control-resize-mode='fixed' follower-ids='["26"]'
    label-alignment='top-left' label-id='26' ni-control-id='23'>
    <div class='ni-glyph '></div>
    <span class='ni-text '>Laden</span>
</jqx-toggle-button>

 

 I also tried to edit the buttons in the html view to jqx-switch-button but as soon as I close the window the changes get discarded. Maybe I miss something verry obvious or is it really not possible to add a normal switch button right now?

 

Thanks in advance 🙂

0 Kudos
Message 1 of 3
(2,355 Views)

Did you try changing the "mechanical action" setting on the buttons? Note that the HTML element is of the same type when configured with any of the mechanical action options (jqx-toggle-button).

 

ANSujay_0-1581330523338.png

Sujay Narayana
Principal Software Engineer
0 Kudos
Message 2 of 3
(2,134 Views)
Solution
Accepted by topic author Jens_S

Yes I tried all of the different behaviors but the result is always the same. I found an example of NI where they also had an simple button with the normal behavior you would expect from a button. What they did is this:

 

Jens_S_0-1581332680260.png

And it somehow works 🤔

0 Kudos
Message 3 of 3
(2,126 Views)