From 04:00 PM CDT – 08:00 PM CDT (09:00 PM UTC – 01:00 AM UTC) Tuesday, April 16, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Need help simulating a myRIO device

I am starting a project with Labview, but I dont have access to a myRIO device yet. My professor has assured me that there is a way to simulate the device, but i havent been able to do it. Im using Labview 2021 SP1 because i havent found the 3 modules i need on the 2023 version (Real time, myRio toolkit and FPGA modules). So far i have gotten to this:

I create a new project (I have tried creating a MyRIO project but of course there is no myrio so i choose "generic target" on the target, i have also tried blank project)

I go on the Project Explorer and right click on project and go New -> Targets and devices and choose New target or device and pick myRIO-1900

I right click on the chassis and go New -> FPGA Target, and then i right click on the FPGA target and i select Simulation on Select Execution Mode.

Now Im supposed to be set up but the myRIO target is missing an IP adress (What am i supposed to do? There is no device, there is no IP adress). Then i right click on the myRIO target and create a VI but when I try deploying anything I get a Connection failed error. If i create the VI from the FPGA i cant add the myrio blocks on the diagram, so i dont think i should be going that way. I have tried giving the device a generic ip adress but it still has a connection error.

What can i do?

0 Kudos
Message 1 of 3
(727 Views)

Your professor is almost certainly mixing up the simulation capabilities of most of the DAQmx devices (but not all) and the myRIO. I have never seen a way to actually simulate a myRIO. Such a simulator would be really a difficult thing to build.

 

What you can do with the myRIO:

 

You can create a new device without having the actual hardware available yet and then can develop code for it and even compile the FPGA bitfile for it. But there is no way to deploy or even run the created code on a non-existing device.

 

For that you open a new project and then right click on the project item and select New->Targets and Devices. Then you select New Target or Device and in the list move to myRIO.

 

If you do not see any "Real-Time CompactRIO" or "myRIO" category you have not installed the correct CompactRIO driver version. If only the myRIO is missing then you have a CompactRIO driver version that does not support myRIO. NI Compact RIO between 20.5 and 22.something did not have proper support included for myRIO support. The latest versions since 22Q3 are supposed to have some support again, but I never was able to confirm that. Instead you may need to install this in addition to CompactRIO. But as it is at version 21.5 it may not support LabVIEW 2022.

Rolf Kalbermatter
My Blog
0 Kudos
Message 2 of 3
(698 Views)

I have been (very actively) using the myRIO for the past several years.  @Rolf is correct that the specific software for the myRIO is contained in the myRIO Software Toolkit, which in the last few releases has been more difficult to install.  It also appears to work only with specific versions of LabVIEW.

 

For example, I am currently working on a myRIO project using LabVIEW 2019 SP1 32-bit, and the myRIO Software Toolkit 2019.  When LabVIEW 2020 was released without a comparable myRIO Software Toolkit, I attempted to migrate my efforts to LabVIEW 2020 and use the myRIO Software Toolkit 2019.  This turned out to be (maybe) possible, but (a) it wasn't easy, nor robust, and (b) it did not give me the "LabVIEW for myRIO" environment that provided, for example, the myRIO Palette for the Real-Time Block Diagram, showing the Express VIs that simplify using the DAC (and DAQ) capabilities of the myRIO.

 

With the release (on the same day as the release of LabVIEW 2022 Q3) of the myRIO Software Toolkit 2021 (at last!), I spent several months trying to build a LabVIEW 2021 system that would include this Toolkit.  I succeeded once (by accident, I'm sure), but was unable to replicate this success, due to repeated crashes of NIPM while trying to do the installation.  I have discussed this issue in the "NI Academic Hardware" Forum here .  I have not yet fully "migrated" to LabVIEW 2021 for the myRIO work, as it would involve migrating the rest of the team who are not yet ready for the move. 

 

My advice at the present time is to standardize on LabVIEW 2019 SP1 32-bit with the LabVIEW 2019 myRIO Software Toolkit.  It is much easier to set up, will (probably) not crash NIPM during the installation, and if it does, it will be quicker and easier to "remove all NI Software and Start over".

 

Bob Schor 

0 Kudos
Message 3 of 3
(682 Views)