LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI MXS 16.0.0 installation has failed with Error 1722 in Windows 7

Solved!
Go to solution
Highlighted

I am installing LabVIEW 2016 32 bit and 64 bit in a Windows 7 Professional PC. At 72% I am encountering an error station that NI MXS 16.0.0 installation has failed with the following Error 1722. It happens for both 32 & 64 bit LV16. But when I install it on another PC with the same specification (except for processor), it is working fine. I reinstalled the OS and again installed freshly, still, the issue is coming again. I have attached a picture of the error. 

do_what_you_like
Download All
0 Kudos
Message 1 of 3
(647 Views)
Highlighted

There are some details that might have been helpful in diagnosing the "why", but here are some suggestions about how you might "fix" it, regardless of the "why":

  1. Start with a "clean" Windows 7 system, one with all NI Software removed.  The (only?) safe way to do this is to go to Control Panel, Programs and Features, select NI Software, and "Remove All".  You might also want to remove "VISA" and "VIPM".  Following this, remove folders from C:\Program * (includes "Files", "Files (x86)", "Data" -- these are the Windows 10 folder names, I think the Windows 7 names are similar) that are named "National Instruments", "JKI", and "VIPM".  Be sure you can see "hidden folders".  For safety, you can rename, rather than delete, folders (add "old" to the Folder name, delete once you've had a successful install).
  2. Get a good "installation" set of files.  If you have an NI-provided distribution kit, feel free to use it.  Otherwise, do a Web Search for the Web-based Installation.
  3. Unless you really need 64-bit LabVIEW, install only 32-bit LabVIEW.
  4. Start the installation by installing only LabVIEW and VIPM.  Reboot after the installation and Activate.
  5. Install any Toolkits and Modules.  Do not install Device Drivers.  Reboot.
  6. Install Device Drivers.  Reboot.

This should work.  It has worked for me multiple times, on both Windows 7 and Windows 10.

 

Bob Schor

0 Kudos
Message 2 of 3
(622 Views)
Highlighted
Solution
Accepted by topic author Pranesh_25

Thank you for your feedback. I tried your solution by removing all NI products from PC. And when I contacted NI they told me to disable the antivirus and Firewall before starting the installation. So after disabling the firewall there was no error in installation. LabVIEW was installed successfully. Thank you for your timely support.

do_what_you_like
0 Kudos
Message 3 of 3
(566 Views)