LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-DCPower Functions and Examples not showing up in Labview 2017

Solved!
Go to solution

I have a PXIe-8880 controller in a PXIe-1085 chassis running Windows 10 and Labview 2017SP1.  I also have a PXIe-4144 SMU.  I have tried installing multiple versions of NI-DCPower including the latest version (20.7) that shows compatibility with Labview 2017, but neither the NI-DCPower functions or examples show up in Labview.  My PXIe-4144 SMU shows up in MAX and is functional as I can run it using the MAX Test Panel.  Is there some known compatibility issue between Labview 2017SP1 and NI-DCPower that I'm not aware of?  Thanks in advance for the help.

0 Kudos
Message 1 of 5
(220 Views)

There is no known compatibility issue that I am aware of.

I have some general debugging questions to start with for you:

 

  1. How are you determining that the support is not present? Are you not seeing it on the LabVIEW palette and the examples in Example Finder?
  2. How are you installing? Are you ensuring that you select installation of LabVIEW 2017 support?
  3. Was this on a clean system, or an upgrade?
  4. LabVIEW 2017 SP1 32-bit or 64-bit?

 

Tobias
Principal Software Engineer
Driver Software
National Instruments
0 Kudos
Message 2 of 5
(214 Views)

Thanks for the reply.

 

1.  Yes I do not see the functions in the Labview palette or the examples in the Example Finder.  I've also looked in the explicit directory on the hard disk as well and they are not present.

2.  I am installing using the Package Manager.  I do not recall seeing a selection for "Labview 2017 support" during the installation.  I've included a screenshot from MAX showing hardware and software versions installed.

3.  Upgrade

4.  32 bit

0 Kudos
Message 3 of 5
(200 Views)
Solution
Accepted by topic author johnsoja

If you uncheck the Product option in the NIPM, you should see NI-DCPower Support for LabVIEW. If you don't see it, go to the PACKAGES tab to install it. If you don't see the PACKAGES tab, click on the Settings icon and enable all options.

ZYOng_0-1708564413829.png

 

0 Kudos
Message 4 of 5
(163 Views)

Thank you so much for the help!  That fixed my issues.

0 Kudos
Message 5 of 5
(117 Views)