LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-DAQmx Driver support for Labview 2017 is missing

Hi everyone, 

 

I am attempting to salvage a VI, made by an employee no longer with the company, in Labview 2017 from a company computer. All went well until I updated DAQmx to version 20.7, which is the latest version compatible with Labview 2017. Now DAQmx is not working with Labview at all, and NI Max cannot connect to the DAQs. Opening the VI in question gives the error message in the title of this post "NI-DAQmx Driver support for Labview 2017 is missing and is referenced by the following vis:"

 

Based on other threads on these forums, I feel confident that the issue is the missing "NI-DAQmx support for LabView" Drivers in the NI Package Manager. However, I cannot seem to find the option to download them under any circumstances. I have attached screenshots of the options I get when installing DAQmx as well as the items currently in the package manager. 

 

Any assistance is much appreciated - thanks in advance!

0 Kudos
Message 1 of 5
(417 Views)

Your screenshots appear to have not been attached after all...

 

At any rate, while I don't have 2020 DAQmx, I do have 2021 and it installed support for 2018 LabVIEW just fine.  When I was doing the install, there was a point during the install during which there was a bunch of recommended packages to install at the same time, and I could scroll down and there was a checkbox for LabVIEW 2018 (32 bit) driver support to install at that time.  I am pretty sure it was checked by default, though it's been a while.

0 Kudos
Message 2 of 5
(403 Views)

As I understand it, you have a LabVIEW 2017 VI (presumably a complete LabVIEW Project developed in LabVIEW 2017) that was developed by a former employee, and you are attempting to get it to run again.

 

It is not clear to me what environment you are using to get this code to run.  Do you have the original Windows 10 PC with LabVIEW 2017 that was used for the initial development?

 

You also mention updating DAQmx to LabVIEW 2020 (I assume that's what you mean by "DAQmx to version 20.7").

 

Have you tried building a PC with a "pure LabVIEW 2017" installation (you may need to use an "offline installer" for LabVIEW 2017)?  If the code worked once with LabVIEW 2017, it should work again ...

 

Once you get the code working on LabVIEW 2017, you can try migrating it to more recent versions of LabVIEW.  Again, it might behoove you to create a separate PC with a more recent LabVIEW installation, and installing a (single) newer version of LabVIEW (say, LabVIEW 2019, or LabVIEW 2020, or whatever you and your colleagues are currently using), and see if the code still works.

 

Bob Schor

0 Kudos
Message 3 of 5
(136 Views)

My mistake! Could have sworn I attached them. Trying again on this one. 

 

Screenshots should show what you're describing because that all sounds the same as what I experienced, except that the particular package in question wasn't listed in the that queue. 

Download All
0 Kudos
Message 4 of 5
(102 Views)

Hi Bob, thanks for stopping by! You are correct that I have a Labview 2017 VI that was fully developed in LV 2017. I am attempting to run it on the original Windows 10 PC with LV 2017 still installed. 

 

When I first received the error message (in one of the screenshots above - sorry about the omission from the original post!) I attempted to rectify it by re-installing DAQmx from this link: https://www.ni.com/en/support/downloads/drivers/download.ni-daq-mx.html#382067 

 

I chose version 20.7 because this chart showed it as the latest version compatible with LV 2017: https://www.ni.com/en/support/documentation/compatibility/16/ni-daqmx-and-labview-compatibility.html

 

What I'm not understanding is why the "DAQmx support for LabView" package is missing from my installation. My current installation should be a "pure" LV 2017 install, but I can certainly try re-installing LabView altogether if you think it would help!

 

Again, thanks very much for your help! 

0 Kudos
Message 5 of 5
(99 Views)