LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Matlab scripts are not working with matlab 7

I am trying to run a VI with a matlab script, but after upgrading to Matlab 7 the VI is not working anymore and returns error 1047
0 Kudos
Message 1 of 6
(2,991 Views)
Beppe04 wrote:

> I am trying to run a VI with a matlab script, but after upgrading to
> Matlab 7 the VI is not working anymore and returns error 1047

Many responses to this here on comp.lang.labview. It doesn't work yet
and NI is looking into it. Search the Developer Exchange archive for
relevant information.

Rolf Kalbermatter
Rolf Kalbermatter
My Blog
0 Kudos
Message 2 of 6
(2,991 Views)
This is a known issue and being worked on.

Between MATLAB 6.5.1 (R13.1) and 7.0 (R14), the Mathworks changed the behavior of the COM interface to MATLAB. The LabVIEW MATLAB Script Node uses the R13.1 compatible behavior. The problem is with passing real values to R14. Complex values work correctly.

Workaround: Change the types of input terminals of the MATLAB Script Node to complex datatypes.

Solution: NI will post a KnowledgeBase article with a permanent solution when it is developed.

Jon Bowers
Applications Engineer
NI UK
0 Kudos
Message 3 of 6
(2,992 Views)
In order to keep any further discussion on this topic in a single location, please refer to this thread for more information.
0 Kudos
Message 4 of 6
(2,991 Views)
Dear Jon Bowers
I am facing the same problem with Matlab 7.  Is there any permanent solution? Please let me know about the same.
Regards,
Basanta
0 Kudos
Message 5 of 6
(2,689 Views)
It will depend on what version of LabVIEW and MATLAB® you are using together. You might check here for more information.
Jarrod S.
National Instruments
0 Kudos
Message 6 of 6
(2,665 Views)