Showing results for 
Search instead for 
Did you mean: 

MODBUS Library query not executable

Hello Everybody,


I have made a simple program in LabView by using modbus-rtu library Protocol and in which I generate the query but that query showing in error which stats (Not executable) and after the CRC-16 generated when it comes to the read holding registers it shows (error 56). Which stats communication time out and i tried multiple delay as well but no response at the end. 


I have attached the screenshot and also code please anybody could help me in this troubleshooting ERR 56.


Error 56_2.JPG

Front Panel_1.JPG



0 Kudos
Message 1 of 7

Any Specific Reason for Starting address as 1152, Usually it should start with 0.

Palanivel Thiruvenkadam | பழனிவேல் திருவெங்கடம்
LabVIEW™ Champion |Certified LabVIEW™ Architect |Certified TestStand Developer

Kidlin's Law -If you can write the problem down clearly then the matter is half solved.
0 Kudos
Message 2 of 7


because starting register (Upper and Lower)

Like 0480H converting into decimal it will be 1152 

and No. of holding register 0004H thats why I split it into two one upper and one is lower register mentioned in figure.

0 Kudos
Message 3 of 7

It's a stretch, but try reading from register 41152 or register 41153. Holding registers generally, but not always, start at register 40001. I've come across many devices where the documentation states it's at something like register 7, but I really have to read 40008.

0 Kudos
Message 4 of 7

Double check the connection settings. If the address is invalid, you should get a different error. A timeout means there is no response at all.

0 Kudos
Message 5 of 7

Connection are ok and as per document it stats that when certain LED or steadily illuminate like i have attached the description down please check




0 Kudos
Message 6 of 7

I have check the connection as well its all good and according to the manual it stats below i have attched the snapshot.




0 Kudos
Message 7 of 7