LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Limit Check Result.VI not working

Hello,

I have Sub-VI for showing the limit check result that displays the result after a limit check is performed as 0-PASS, 1-FAIL and 2-MARGIN. I cannot get it to display(report) the correct value. 

 

Thank you

0 Kudos
Message 1 of 7
(1,555 Views)

You provide insufficient information. Where does C/Matlab fit into all this? Have you contacted the driver mfg.?

0 Kudos
Message 2 of 7
(1,546 Views)

Matlab doesn't fit in anywhere. I'm using labview2013

 

As you can see the posted screenshots. 

I connect to a R&S FSV40-->recall saved state(with limit lines configured)-->attempting to read limit check result.

 

 

0 Kudos
Message 3 of 7
(1,537 Views)

Contact rohde-shwarz, they wrote the VI.

0 Kudos
Message 4 of 7
(1,531 Views)

Hi,

 

the most important thing in remote-control: never use continuous measurement mode. Check out our 10 tips/tricks for LV drivers:

https://www.rohde-schwarz.com/applications/10-tips-tricks-on-how-to-use-rohde-schwarz-labview-instru...

 

You do save/recall, you are in contiunous mode, your program runs faster than your instrument's sweep and therefore you get incorrect limit check result.

 

After File Recall:

- call Configure Acquisition.vi with Sweep Mode Continuous=false

- call Initiate.vi - this performs the sweep and waits for it to finish

- call LimitCheck

 

Tip: in the Express VI configurator you can use the Hi-Level Function tab to see and use hi-level function where the desired attribute is used (see the picture in the attachment)

 

Happy remote-controlling 🙂

 

Message 5 of 7
(1,444 Views)

Hi MM_RohdeSchwarz

 

Thank you for responding to my question.

 

I have implemented the .VI you listed: 

- call Configure Acquisition.vi with Sweep Mode Continuous=false

- call Initiate.vi - this performs the sweep and waits for it to finish

 

I still get the same result. please see my attached video.

 

Thanks

Download All
0 Kudos
Message 6 of 7
(1,424 Views)

Hi jbent,

 

sorry, I forgot to mention one other thing - you have to tell the analyzer which limit is your Limit1 - that can not be done with the setup file, you have to set it afterwards. Find my working example in the attachment. Let me know if it worked.

 

BR

Milo

0 Kudos
Message 7 of 7
(1,407 Views)