LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2016 new improvments to selecting, moving and resizing objects

Solved!
Go to solution

Hi!

 

Below are new Labview 2016 improvments

 

Improvements to Selecting, Moving, and Resizing Objects

LabVIEW 2016 includes usability improvements to selecting objects, moving objects, and resizing structures on the front panel or block diagram.

  • Selecting Objects
    • When you select objects, the area covered by the selection rectangle displays in gray and a marquee highlights the selected objects. Selected structures appear with a darker background to indicate your selection includes them.
    • By default, when you create a selection rectangle around objects, you must enclose the entire structure or the midpoint of a wire segment to select it. If you press the spacebar when you create the selection rectangle, you select any objects that the selection rectangle touches. To restore the default selection behavior, press the spacebar again.
  • Moving Objects—When you move selected objects, the entire selection moves in real time. Certain objects, such as structures, rearrange or resize to accommodate the movement of the selected objects.
  • Resizing Structures—When you resize a structure by dragging the resizing handles, the structure grows or shrinks in real time instead of displaying dashed borders.

 

I find those things great in certain situations but it slows computer a lot. Does anybody know if you can turn off those feauters? I have an i5 with an SSD and 4 Gb RAM but if I have larger VI the lag when moving objects with those new feauters is quiet a big. It feels like I play a game with 3 FPS.

Message 1 of 23
(5,834 Views)

I'm seeing the same slowness using LabVIEW 2016 64-bit.  For example, pressing Ctrl and dragging a case structure to copy it, takes a long time - moves really slow.  Some actions on the Quick Drop are also slow such as Ctrl-R to remove objects and rewire.  I'm running on a i7 with 16 GB RAM with Windows 7 Pro. 

Message 2 of 23
(5,721 Views)

Do you have a large block diagram?  Do you have the navigation window open?

 

If yes to both of those things, many actions on the block diagram are slow because LabVIEW takes a long time to recalculate what the navigation window would look like

 

So if you have the navigation window open, close it and try again.

0 Kudos
Message 3 of 23
(5,693 Views)

No I dont have navigation window open. The problem is it is slow regardles of navigation window open.

0 Kudos
Message 4 of 23
(5,686 Views)

I don't use the navigation window.  The block diagram is quite large; about 1600 nodes. 

0 Kudos
Message 5 of 23
(5,645 Views)

Reading this thread reminds me of an war story...

 

Years ago my sister and her husband were moving to Florida. They purchased a used van and rented a trailer. We loaded it up with everything they had. They got about a mile down the road when the transmision blew out. Turns out it was cheaper to pay AAA to haul the van to Florida than to try and fix the transmision and pay for another truck rental.

 

The moral of that story was "If you over-load something, do not be suprised if it fails."

 

The same thing applies to Dremel tools, drills, and LV.

 

Just my 2 cents,

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
Message 6 of 23
(5,640 Views)

The 'Audio Analyzer.vi' from the Sound and Vibration sample project right out of LabVIEW 2015 templates has 1667 nodes.  The 'SFP Dynamic Signal Analyzer.vi' from the Dynamic Signal Analyzer sample project has 2062 nodes. And so are some other sample projects right out of LabVIEW are just as big.  I don't think this is uncommon.  The point is that LabVIEW 2015 has no speed issues with these large subVIs. Refactoring some of our controller type subVIs could be expensive; I don't think the customer will pay for the restructuring just to be able to run it in 2016.  The question still remains if there's a way to disable these great looking features from LabVIEW at least temporarily.

0 Kudos
Message 7 of 23
(5,607 Views)
Solution
Accepted by aucman

If you find live drag too sluggish, you can temporarily toggle it off by pressing the 'x' key during the drag.

It will revert to live drag for the next drag.

 

You can add 'LiveDrag=False' to your LabVIEW.ini file to disable live drag by default.  When live drag is turned off, you can still toggle it back on for a single drag by pressing 'x'.

 

Also, if any single refresh during a drag takes longer than 200 ms, LabVIEW will automatically turn off live update during the drag.  We are aware that for very large panels or diagrams, performance could be an issue, and this was an attempt to automatically mitigate that, but perhaps 200 ms was too conservative.

 

Craig Smith

LVR&D

Message 8 of 23
(5,585 Views)

'LiveDrag=False' in the ini file worked.  So is the 'x' while dragging. Thanks so much for the tip!

Message 9 of 23
(5,565 Views)

Tnx. I tested it and for moving objects it is working great. Especially x key is great. I couldnt made it to work when holding CTRL key (copying). If anybody will have time to figure it out thanks in advanced.

0 Kudos
Message 10 of 23
(5,558 Views)