Showing results for 
Search instead for 
Did you mean: 

LabView is crashing

Go to solution

I am very new to LabView, we are using LabView for data logging the temperature in our ovens. The LabView session has been crashing during some of the baking times. Our baking times are anywhere from 1 to 4 hours. It seems like most of the crashes happen around 25-30 minutes into the run. I have tried to attached the error log and the .vi, but it will not let me. I have copied the lvlog data below. Any help would be greatly appreciated. Thanks.


#Date: Mon, Sep 19, 2022 10:00:23 AM
#OSName: Windows 7 Professional Service Pack 1
#OSVers: 6.1
#OSBuild: 7601
#AppName: LabVIEW
#Version: 14.0f1 32-bit
#AppKind: FDS
#AppModDate: 8/29/2014 13:57 GMT
#LabVIEW Base Address: 0x00400000

InitExecSystem() call to GetCurrProcessNumProcessors() reports: 2 processors
InitExecSystem() call to GetNumProcessors() reports: 2 processors
InitExecSystem() will use: 2 processors
starting LabVIEW Execution System 2 Thread 0 , capacity: 24 at [3746444423.89727690, (10:00:23.897276879 2022:09:19)]
starting LabVIEW Execution System 2 Thread 1 , capacity: 24 at [3746444423.89727690, (10:00:23.897276879 2022:09:19)]
starting LabVIEW Execution System 2 Thread 2 , capacity: 24 at [3746444423.89727690, (10:00:23.897276879 2022:09:19)]
starting LabVIEW Execution System 2 Thread 3 , capacity: 24 at [3746444423.89727690, (10:00:23.897276879 2022:09:19)]
00 00 03 07 78 9C 63 60 60 F8 CC C8 C0 C0 F0 05
48 F0 4C 63 02 B2 18 99 B1 93 F2 24 B2 B5 F0 19
C6 81 C4 66 05 5A CD A4 0A 66 F6 80 C9 2E 24 B2
07 89 34 C1 67 22 92 59 06 60 A6 27 92 70 38 76
85 2D C4 1A CB 81 C7 E9 AC 0B D1 AC 63 97 0F C0
6A 1D 7B 34 98 99 88 C7 E9 EC F7 F1 E8 E7 38 09
66 36 63 F8 08 24 C9 AC 4B D8 2F 20 75 6C 72 60
66 02 3E 25 0D 78 C3 0F 6C DB 6E AC 3A 59 04 98
B1 8B FB 83 BC C5 FA 06 5D 78 15 56 D5 AC BC D8
4D E1 DB 89 4B 98 E8 B4 0A 52 CF 3F 0D 55 3D 50
48 20 1A 00 DC 92 17 B6 0A 52 CF 3F 0D 55 3D 50
"vi": "C:\\Program Files (x86)\\National Instruments\\LabVIEW 2014\\vi.lib\\ULx\\Create Channel.llb\\ULx Create Channel (AI-Temperature).vi",
"ctx": "Main Application Instance",
"type": "subVI"
"vi": "C:\\Users\\heattreat\\Documents\\MG32\\MG32 LabView",
"ctx": "Main Application Instance",
"type": "topVI"
] }

9/19/2022 12:00:55.868 PM
Crash 0x00000000: Crash caught by NIER
File Unknown(0) : Crash 0x00000000: Crash caught by NIER
minidump id: 5538cc18-0140-4bab-afd2-448160007715
ExceptionCode: 0xE0434352

0x100011AB - nierInterface <unknown> + 0
0x10005E86 - nierInterface <unknown> + 0
0x1000620C - nierInterface <unknown> + 0
0x761503CF - kernel32 <unknown> + 0
0x773950D7 - ntdll <unknown> + 0
0x773597E5 - ntdll <unknown> + 0
0x00000000 - <unknown> <unknown> + 0

0 Kudos
Message 1 of 14

This kind of error log is not useful.  No body understand it except NI.


A wild guess:

Are you calling "C:\\Program Files (x86)\\National Instruments\\LabVIEW 2014\\vi.lib\\ULx\\Create Channel.llb\\ULx Create Channel (AI-Temperature).vi" in a loop over and over again?


If you want get help from other LabVIEW programmers, you should post your diagram.


George Zou
0 Kudos
Message 2 of 14

Who wrote the program? If it crashes after a long time in "create channels", maybe you are constantly creating new channels and are running out of resources. Can we see the code?

0 Kudos
Message 3 of 14

You are very new to LabVIEW, your program crashes (but only after running for a while), you seem to be running on Windows 7 (!), seem to be running LabVIEW 2014 (but there is also a hint of LabVIEW 2022).


Something is clearly "wrong".  We might be able to help, but we need specific information, including:

  • In broad strokes (no details necessary, yet), what are you trying to do?  We know it involves measuring Temperature, but details as to "with what?", "how often (a.k.a. Sampling Rate)?", "how much (a.k.a how many channels)?", and "so what? (a.k.a. what do you want to do, and when, with your measurements).
  • Tell us about the PC (or Mac?) you are using.  What OS?  64-bit or 32-bit?  Note most of the Community will be using Windows 10, 64-bit.
  • Tell us about your LabVIEW environment.  What Version?  What "bit-ness" (many/most? of us use 32-bit).
  • Tell us about your DAQ devices.
  • Tell us about your LabVIEW experience(s).  If "someone else" wrote the code, did it ever work properly?
  • Is your code part of a "LabVIEW Project" (i.e. is there a .lvproj file associated with your code?).
  • Finally, we need to examine (all of) the code, as that is almost certainly the source of your problem.  If your code is structured as a LabVIEW Project, and if all/most of the code is contained in a single Folder, compress the Folder and attach the resulting .ZIP file to your reply.

Bob Schor

0 Kudos
Message 4 of 14


First, I agree with Bob's points above. Providing that information would be useful.

I can't tell the cause of the crashes from the lvlog data. But thanks for attaching it - it does contain useful information.


Crashes can happen due to "memory leaks". A memory leak is when a program, written in LabVIEW or other programming language, uses more and more memory as time goes on, until it reaches a maximum limit allowed by the operating system.


You can use a few tools to check if a memory leak is occurring: Windows Task Manager, Windows Resource Manager, or Process Explorer (from the SysInternals suite of Windows monitoring and troubleshooting tools).

In Task Manager, look at the "Memory" column. If that number keeps growing, it indicates a memory leak. There isn't a plot or graph function in Task Manager.

In Process Explorer, right-click on LabVIEW.exe in the list of processes, and select Properties. Then, select the "Performance Graph" tab. You should see something like below.

Using Process Explorer.png

If the "Private Bytes" keeps constantly rising, that means that a memory leak is occurring in one of the VIs of the LabVIEW application (not necessarily inside "ULx Create Channel (AI-Temperature).vi" or "MG32 LabView" ).

If your investigation reveals that it is indeed a memory leak issue, the solution is to modify the LabVIEW source code. This is not trivial. It needs to be done by someone who understands LabVIEW well. Common causes of memory leaks are: an array or a queue whose size keeps growing (more and more elements are added to the array or queue).

Some other questions:

  • You say that "The LabView session has been crashing during some of the baking times". So LabVIEW sometimes doesn't crash? If so, what's different between when it crashes and when it doesn't crash? Is the baking duration shorter when it doesn't crash?
  • Do you get any error message when LabVIEW crashes? Attaching a screenshot of it might help.
0 Kudos
Message 5 of 14


  Wow, thank you to everyone who posted here, very speedy reply's.

  • We are using this program to track our heat treating of metal, it takes temperature readings from 2 thermocouples (channels) in the oven every 2 minutes. It also starts the soak time once it reaches a certain temp. We record these temperatures to an excel file for proof of heat treating our parts.
  • The PC is a dual core Pentium E5700, 64 bit OS, with Windows 7 Professional
  • Our LabVIEW is version 2014 14.0f1 (32-bit) Base development system, memory allocated 51628K
  • Our DAQ unit is a Measurement Computing USB-TC using 2 channels
  • My LabVIEW experience is changing the directory where the data is being saved. I did read through a beginner tutorial I found online from SDC publications. Someone else wrote this program and he no longer works here. I would have to believe it worked without crashing, but I can't say for sure.
  • I do not see a .lvproj file. We click on a shortcut on the desktop that opens a .vi file.
  • Hopefully my zip file loads this time.

Thanks Brian

0 Kudos
Message 6 of 14


  • I ran the Task Manager and Resource Monitor and it started at 114,216kb, 30 minutes in it was at 116,096kb, 60 min in it was at 102,588kb.
  • See the zip I attached to Bob's reply for files and pictures. 
  • Bake time doesn’t seem to matter on weather is crashes or not. We can be running a 1 hour or 4 hour cycle and it will make it sometimes or sometimes it will crash. I am not sure what the difference would be.



0 Kudos
Message 7 of 14

Please only attach real zip file. Any proprietary archive (e.g. *.7z) lower the chance that somebody will even look at it. Nobody should need to install extra software just to open your attachment. Use whatever is built into the OS!

0 Kudos
Message 8 of 14

Thanks for the info. I have attached the standard zip file.

0 Kudos
Message 9 of 14

A couple of things stick out at first glance...

  1. You are creating a new AI Temperature task with every iteration of your loop
    1. Create the task THEN enter your acquisition loop
  2. You have your data file hard coded to the "S" drive 
    1. Is this a network drive? If so, is it always available?
  3. You have no Error Handling 
    1. Connect the Error Cluster!   


Judging by the error message possible cause (....Ulx Create Channel) I am leaning towards #1

But #2 and #3 also need to be addressed 

=== Engineer Ambiguously ===
0 Kudos
Message 10 of 14