LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabView Can't find connected instruments

Solved!
Go to solution

Hello, I am new to Labview. I have installed Labview 2018 on my system(OS Win10) and I use a Keithley GPIB card to which I have connected three instruments (Keithley 2000 Multimeter, Amtek 7265 DSP Lockin Amp and a Standford Research 830 Lockin Amp). I have also installed Keithley GPIB 488 driver and I can see the GPIB card listed in Device Manager as GPIB interfaces. In NI MAX i can only see 'KPCI 488A' under devices  and interfaces. I guess this is the GPIB card. 

But LabView is showing "no connected devices"  and when I search for the instrument drivers for these instruments, LabView cannot find any driver. I remember it used to work when I had installed it on another system some time ago.

Moreover, NI Max also does not show the three instruments that i have connected. 

** I have just installed LabView 2018 and GPIB driver for the keithley card. Nothing else. I have attached a screenshot of NI package manager here in case it helps

 

Please help !!

0 Kudos
Message 1 of 19
(903 Views)

You probably just need to enable the Tulip Driver in NI-Max

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 2 of 19
(853 Views)

Make sure that NI-VISA is also loaded.

Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
Message 3 of 19
(837 Views)

@Minions wrote:

Make sure that NI-VISA is also loaded.


Oh yeah I tend to assume that NI-VISA and NI-488.2 is installed.

 

In my experience both are usually needed so I always install them by default.

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 4 of 19
(824 Views)

Thank you for suggestion. I installed NI VISA 18.0 and now LabView can detect the three connected instruments and also I can see them in NI MAX. But I still cannot find drivers for Keithley, Amtek or Standford Research 830 in LabView Find Instrument Drivers option. It says there is no driver for the searched option. But as I remember I had installed drivers on a different system earlier using Labview 'Find Instrument Drivers'  option.

Am i missing anything else ? 

 

Thank you 

0 Kudos
Message 5 of 19
(798 Views)

@AbinashB wrote:

I had installed drivers on a different system earlier using Labview 'Find Instrument Drivers'  option. 


That option commonly breaks when NI changes something in their servers.  Go here and search for your instruments: https://www.ni.com/en/support/downloads/instrument-drivers.html 


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 6 of 19
(792 Views)

Hi Abinash,

 


@AbinashB wrote:

Am i missing anything else ? 


Look for drivers on NI.com/IDNet

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 7 of 19
(781 Views)

@AbinashB wrote:

 I still cannot find drivers for Keithley, Amtek or Standford Research 830 in LabView Find Instrument Drivers option. It says there is no driver for the searched option. But as I remember I had installed drivers on a different system earlier using Labview 'Find Instrument Drivers'  option.

 


Honestly for instrument drivers I find I get better results by going directly to the instrument manufacturers website first.

 

Then check the NI IDnet

 

Then ask here on this forum if anyone has written their own

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 8 of 19
(759 Views)

All three of the instruments can be controlled without the drivers by using the SCPI or SCPI-like programming commands found in the instrument manuals.

Help the Community (and future reviewers) by marking posts as follows:
If it helped - KUDOS
If it answers the issue - SOLUTION
0 Kudos
Message 9 of 19
(747 Views)

I did go to NI instrument driver network and found the drivers for standford research 830 and keithley 2000 against LabView 18.0. But when i click on download, nothing happens !! I had installed these drivers on a different system earlier. Is there any way i can take them from the other system ?? !!

 

Thank you

0 Kudos
Message 10 of 19
(736 Views)