Showing results for 
Search instead for 
Did you mean: 

LabVIEW PPL Version not visible in Windows Explorer

Hi all


I'm new to PPL's and i tried to deploy a PPL to a prodcution machine with windows 10 and only LabVIEW Runtime installed.

Know i wan't to verify that i have the correct PPL-Version on the Production machine but the Version-Property is not visible:



On the development machine with Full LabVIEW installed the version-property is visible.

Is it because *.lvlibp is a unknown filetype?

How to solve this behaviour?


Best regards



0 Kudos
Message 1 of 4

Hello to all


Is my question not clear or is there no solution?


Best regards

0 Kudos
Message 2 of 4

There is a hidden gem that you can use to get the version information from your PPL: <LabVIEW>\vi.lib\Platform\fileVersionInfo.llb\


I have not tried it on a deployment machine yet, but you could make a very simple utility to get all of the PPL and executable files to check their version.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 3 of 4

Thanks Knight Of NI for your reply


That is a solution but that couldn't be that i have to write a extra utility to get the *.lvlipb Version.


Is there a other Solution?


Best regards 

0 Kudos
Message 4 of 4