LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW HTTP error 363507

Hello all,

In one of my codes I am sending data to cloud vis http command. This command works well in LV2021 development mode and LV2021 and LV2019 exe mode. But in LV2019 development mode it is not working, it is giving error 363507.(see screen shot) 

T_India_0-1711370767501.png

Any clues on why this dependancy on version and how to resolve this? I have LV2021 and 2019 installed on my laptop.

Also, some PCs on shop floor have only LV2019 runtime and still they are giving the same error.

0 Kudos
Message 1 of 6
(351 Views)

Error 363507 When Using the HTTP Client API in LabVIEW

Did you have SSL enabled?

Are you seeing the error on the same computer that works well at the same time?

-------------------------------------------------------
Control Lead | Intelline Inc
0 Kudos
Message 2 of 6
(305 Views)

yes, it is on the same computer.

not sure if it is SSL enabled. Where can I check it? But it is working with LV2021 development mode.

0 Kudos
Message 3 of 6
(297 Views)

Wasn't it 2020 that they enabled using the OS' available certificate chains instead of just the ones that ship with LV?

~ The wizard formerly known as DerrickB ~
Gradatim Ferociter
0 Kudos
Message 4 of 6
(291 Views)

@IlluminatedG wrote:

Wasn't it 2020 that they enabled using the OS' available certificate chains instead of just the ones that ship with LV?


2020 or thereabout. And yes it is almost certain that the certificates coming with the NI flavor of OpenSSL that is delivered with 2019 are far outdated by now. Certificates expire regularly and without keeping the certificate store up to date you are bound to get problems. Allowing to use the OS certificate store in more recent LabVIEW versions did remove that extra problem of having to update an independent root certificate store.

 

If you absolutely need to work in LabVIEW 2019 you may have to edit the certificate store that the LabVIEW 2019 HTTP Client VIs uses. This Knowledge-Base article describes how to edit the according ca-bundle.crt file. Or you could take a new ca-bundle.crt file from a recent OpenSSL distribution and put it in there.

Rolf Kalbermatter
My Blog
0 Kudos
Message 5 of 6
(273 Views)

Hello,

Sorry for the late reply. Thank you for the inputs. I switched to labview version 2021 and initially it worked but now again after few weeks I am again getting error 363507.

FYI this code works from my personal laptop but the error appears only on our tester PCs in factories which are on OT network.

Any idea why this is happening?

0 Kudos
Message 6 of 6
(120 Views)