From 08:00 PM CDT Friday, August 12 - 01:00 PM CDT Saturday, August 13, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW Error Code -63040 on sbRIO 9632

Solved!
Go to solution

Hello.

 

I'm trying to run the roaming VI on my NI Robotics Platform 2.0 kit and it's giving me the error -63040 which is a communications error. This is not the first time I try to run roaming, as I've been able to do it before successfully (on a different computer) but now it's giving me that error. I've searched around for different ways to fix it, including verifying it's IP, making sure that the PC and robot are on the same network, and even formating the sbRIO board and reinstallling the software but nothing seems to work. I can't find any other way online to fix it. 

 

The code seems to compile right, but then the robot does not move. In the attached image, i've highlighted the process so you guys can see what I"m talking about.

 

Any help on this would be appreciated!

 

0 Kudos
Message 1 of 9
(2,489 Views)

I am going to try and Update the software to a newer version to see if that works. I have to wait until I have administrator access on this computer however. 

0 Kudos
Message 2 of 9
(2,435 Views)
Solution
Accepted by topic author frankenai

Hi,

Unfortunately, this is a very generic error that might be happening due to several situations. Please check some check resources bellow:

RIO Driver compatibility between your HW and Computer:

http://digital.ni.com/public.nsf/allkb/B77CEB8067558F6F86257203007F1E91

 

RIO Server is not running:

http://digital.ni.com/public.nsf/allkb/83DF7B9245541FC8862573A100597696

 

Network Configuration Changes:

http://digital.ni.com/public.nsf/allkb/2367ADE10FDD98C4862576EB005C255D

 

IP Address not correctly configured in the Project:

http://forums.ni.com/t5/LabVIEW/LabVIEW-Error-Code-63040/td-p/1310679

 

Regards,

AGJ

0 Kudos
Message 3 of 9
(2,429 Views)

Thank you for your reply!

 

So if it turns out to be that the RIO server is not running, how do I fix it?  

0 Kudos
Message 4 of 9
(2,409 Views)

Hi Frank,

I would go with reinstalling software on your device but I suppose that you have already tried that. What is the status of your device in MAX? Could you take a screenshot showing the software that is installed on your sbRIO device?

What is the software that you have installed on your computer? LV, LV FPGA, LVRT, RIO Driver? Which versions?

Make sure that everything is compatible between your computer and HW device.

 

Regards,

AGJ.

0 Kudos
Message 5 of 9
(2,377 Views)

Software on the sbRIO is Screenshot_6.png, while the other two are all the software installed on the host. 

 

Everything seems to match the software on the host. 

 

Thank you so much for your help.

 

 

Download All
0 Kudos
Message 6 of 9
(2,348 Views)

I have been trying to set a static port for the NI Rio server to see if that solves the communication issue, but whenever I restart the server after setting the static port number, the server just wont start up, and displays a message saying:

 

"Windows could not start the NI-RIO Server on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vender, and refer to service-specific error code 1715."

 

Not sure what's going on there.

0 Kudos
Message 7 of 9
(2,299 Views)

Hi,

Are you starting the Server from Windows Services? Have you tried putting down your antivirus? Firewall?

 

Regards,

AGJ

0 Kudos
Message 8 of 9
(2,281 Views)

I am dumb. The issue was an IP address, and I didn't notice it the first few times I looked through it since the difference was between 245 and 254. 

 

Thank you so much for all your help!

0 Kudos
Message 9 of 9
(2,243 Views)