LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue in connecting sub VI programs through the main program

Solved!
Go to solution

Hello

I have complied the main program of keithley 2410 that I made own but only two task (Read current and Read voltage) are running and remaining (Initialize, Switch off instrument and Set voltage) are not working while my program is not showing any error. I am sending you all the files (attached).

 

So can you please help me to solve this problem.

0 Kudos
Message 31 of 92
(1,043 Views)

The subVI called write.vi makes no sense. It always does a read. When you call it, you can't even change it to do a write because you don't have the GPIB Action terminal wired to the connector pane. It does not make any sense to have that subVI anyway. Why not just call the Action subVI. At least someone has wired the connector pane correctly.

0 Kudos
Message 32 of 92
(1,033 Views)

Hi Dennis,

 

ymanglik doesn't seem to care about our suggestions - I already pointed to that problem in the last year...

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 33 of 92
(1,013 Views)

I see that now. We need to use a bigger hammer.

0 Kudos
Message 34 of 92
(1,005 Views)

Hello its not like that as you are saying. I am following your suggestions.

Actually I am toataly new programmer to labview so I dont know how to debug the error in some cases like that. As you have mentioned that I dont have the GPIB action terminal wired to the connector pane. I dont know how to connect the GPIB action terminal to the connector pane. Can you please elaborate how to do this.

0 Kudos
Message 35 of 92
(984 Views)
You've been pointed to the help and even a video showing how to do this. Have you read the instructions or watched the video? Please do. It's a quite simple task.
0 Kudos
Message 36 of 92
(976 Views)

About which video you are talking. I didn't receive any video from your side.

0 Kudos
Message 37 of 92
(971 Views)
From udka back on Dec 18.

And, I'd like to point out again, it's just silly to create a Write VI that calls the Action VI. Instead of struggling with something so basic, just use the Action VI everywhere.
0 Kudos
Message 38 of 92
(961 Views)

Hello again appriciate for your support.

I am using Keithley 2410 to measure the voltage. I downloaded labview driver.

I tried to interface the main labview program of keithley(attached) with keithley 2410 device but it generated error #803 which is " Not permitted with output off". I am using labview ver.13 and I have attached all the files.

Please suggest me something to solve this problem.

 

0 Kudos
Message 39 of 92
(927 Views)

Hi ymanglik,

 

that seems to be an error message of the K2410. It IS explained in the instruments manual!

 

You need to debug your program to determine which device/SCPI command isn't permitted with output switched off...

 

Is this suggestion suitable to solve your problem?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 40 of 92
(923 Views)