LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Incremental Encoder Angular Position Issue

Hello,

 

Currently, the angular position output we are receiving is not matching up with what we expected. I have tried two different codes, one using the DAQ functions manually and the other using the DAQ assistant, the former is showing an output, but not the expected output, and the latter doesn't give any output whatsoever. The file of both codes are attached.

 

Download All
0 Kudos
Message 1 of 9
(1,023 Views)

You need to provide more info in this.

 

- What encoder are you using?

- What did you see?

- What did you expect?

- How are you connected to the DAQ device (what channels?

- How is your system powered?

- Are you seeing any response from your system?

Tim
GHSP
0 Kudos
Message 2 of 9
(1,013 Views)

Encoder- ERCKI Series Single Turn Hall Effect (incremental) 5 wire
What we saw- a square wave ranging from 0 to -0.09 (also attaching it below)

What we expect- two square waves, and the angular position outputted in degrees

Powered- 5 V through myDAQ (SCB 68A)

Any response- yes, show below

image.png

 

0 Kudos
Message 3 of 9
(1,002 Views)

- Did you get the TTL or the open collector version?

- If you got the open collector version did you get the 5VDC version or the 9-30VDC version?

 

What channels did you connect to on your DAQ system?

Tim
GHSP
0 Kudos
Message 4 of 9
(989 Views)

We got the TTL 5V

 

Source A is connected to PFI8 a.k.a pin 37

Source B is connected to PFI10 a.k.a pin 45

 

We aren't using Z

0 Kudos
Message 5 of 9
(976 Views)

Still using LV2018, it is impossible for me to open your VIs. I suggest two actions:

 

  1. Check the encoder signals with an oscilloscope.
  2. Make a test with Counter - Read Encoder.vi found in the LV examples (LV menu >> Help >> Find Examples... >> Hardware Input and Output >> DAQmx >> Counter Input).
0 Kudos
Message 6 of 9
(932 Views)

Hi Faith,

 

Did you make any progress on this?

 

Have you ever used NI Max and global virtual channels? You can set up your encoder in NI Max and have it do all of your conversion to measure your encoder. You should be able to go in and set up all of the channels and the encoder type right in NI MAX then in your main program you can just read the value. It is also helpful to troubleshoot if things are working the way you are expecting. The voltages seem off to what I would expect them to be. Do you have to pull up or pull down the signal?

 

aeastet_0-1649177056360.png

 

 

Tim

Tim
GHSP
0 Kudos
Message 7 of 9
(907 Views)

I apologize for the late response, it ended up being an issue with the pin configurations, they weren't securely properly. Once my team fixed that the code began to work, thank you for all the help

0 Kudos
Message 8 of 9
(856 Views)

It turned out to be an issue of both the wires not being properly secured in the DAQ and that I didn't have an external clock source, which I fixed using this link https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P8d2SAC&l=en-US, thank you for all the help and advice though!

0 Kudos
Message 9 of 9
(863 Views)