Showing results for 
Search instead for 
Did you mean: 


Go to solution

My installation is a whole disaster, I first download and install the chinese version LabView but the UI are all messed up with random chinese character, then I uninstall it by using uninstaller and then i delete [National Instruments, IVI foundation, JVK] folder, then when i trying to install the english version LabView, this messege pop-up "unable to load mifsystemutility dll", I followed the instructions on the website and I believe I deleted the wrong registry, then I panic, so I delete all entries i can found with ctrl+f, then i delete all entries related with (NI/national instruments/nipkg/...).
I know this is dumb, but is there any chance i can install LabView😭


//when I trying to install now, this pop-up

An error occurred while installing a package: ni-msdotnet4x (

Additional error information:
Unable to load MIFSystemUtility.dll from the path: ''. Ensure your package depends on the NI-Paths package and that the NI-Paths package has already been installed on the system.

0 Kudos
Message 1 of 6
Accepted by topic author rickychou777

After installing LabVIEW for 10 years for myself and colleagues/students, I encountered LabVIEW 2017 and NIPM.  I also had problems with the installation, did a complete uninstall of LabVIEW (using the only "correct" way, namely via NIPM), and then I did what you did, removed folders and Registry entries.  Following that, I was unable to ever install LabVIEW.


I "fixed" it by backing up my "Profile" (my files and settings), reformatting the C: drive, reinstalling Windows, Office, Browsers, Utilities, and then (with essentially a "new PC" reinstalling LabVIEW.  Of course, if you have a full backup of your system before you installed LabVIEW, definitely do a Full Re-install.


LabVIEW is difficult to install, particularly if you install "more than you need".  When you get a PC that can "accept" a LabVIEW installation, initially install LabVIEW (with no additional Modules or Toolkits, and with very vew Drivers, initially only DAQmx and VISA, and only selected "Additional" features).


Bob Schor

0 Kudos
Message 2 of 6

After trying all solutions from the internet, I reinstall my whole Window system and now I can install it. Thank you.

0 Kudos
Message 3 of 6

If (in the next few days) you find you need to remove LabVIEW and "try again", there is a safe way to do this.  The key thing is to know when to stop!  Here are the steps:

  1. Open NIPM.  Uncheck "Products only" (you want to uninstall everything).
  2. Check the box on the left (above the list of packages) called "Name", which will put check marks on (almost) everything.
  3. Click "Remove".
  4. Wait for it to finish (could take a while, maybe tens of minutes).
  5. Reboot.
  6. Open NIPM.  You should see only NIPM.  If you see other things, stop and post a Message on the Forums.
  7. If you only have NIPM, select to remove it.  You'll get a warning, but that's to be expected.  Remove NIPM.  Reboot.
  8. This should get rid of most NI software (though there will still be folders left -- leave them alone).  There may also be some "early" (pre-2017) files installed that NIPM "doesn't see".  If you want to get rid of them, too, here's how to do it:
    1. On the Windows Search Bar (on the bottom to left of TaskBar), type "Control Panel.
    2. Open Control Panel.  Click on "Programs and Features".
    3. Look for "NI Software" or "National Instruments" (I don't remember exactly how it is listed).
    4. If you find any files there, you can select "Remove all".  If nothing is there, stop, you are done!

Let us know how you do with re-installing LabVIEW.  I suggest to keep a list of what installation options you choose, just in case you run into another snag.  If an error occurs, write dowh the Error message, and post it here.


Bob Schor

0 Kudos
Message 4 of 6

(this message is targeting for those ran into the same issue, and who do not want to reinstall windows just for one app)

As i am unsure if this is pure luck, or actually working way to solving this problem, i am not risking myself into the same situation again, EVER

Actually i ran into the same situation , kept getting the same error while attempting ti re-install the NIPM for labview.


the folders i had removed is


Program Files\ National Instruments

Program Files (X86)\National Instruments

which caused the whole disaster

then i had came to a hard decision to decide if i should wipe all my stuff just for this crappy installer, but after doing some searching of the issue i had found that NIPM installer will just mess around those hidden folders ...

and what i done after is deleting some hidden files
they are located in

Program Data\National Instruments


user\(your user name)\Appdata\Local\National Instruments  (and another National_Instruments in the same folder)

user\(your user name)\Appdata\Local\temp\     <nisomething>    (deleted those nipkg_<numbers> and ni-DotnetInstallerRunner)

(↑CAREFUL : it includes temp files from other apps too )


and lucky enough that i am able to run the installer again, without messing up  the whole regedit


hope it actually helps someone who gone into the same situation

0 Kudos
Message 5 of 6

I will repeat what I have said numerous times before on this LabVIEW Forum -- there is a "safe" way to remove a partial or "bad" LabVIEW installation that was done after 2016 (i.e. LabVIEW 2017 and later), and other "more aggressive" methods run the risk of rendering your PC (actually, probably the Windows Registry) in a state that makes subsequent attempts to install LabVIEW (using NIPM, i.e. any version from 2017 to the latest release) fail.  The only "foolproof" method, I believe, to fix a corrupted Windows Registry is to reinstall Windows.


I have getting close to two decades of experience working with LabVIEW and participating in the LabVIEW Forums.  I don't know anything about @wwwaaa1234wwwwwww, a new member who just joined the Forums today, but would urge extreme caution for anyone to decides to follow the device this New Member provides.  At a minimum, make a backup copy of all your data, and a list of the applications that you are running that you might want to re-install.


Bob Schor

0 Kudos
Message 6 of 6