LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

I can't install ni package manager error: guiexecutablefullpath

I wanted to update from 2019 labview to 2020, so i removed old software and tried to download the new one. now i get this "error: an error when launching the following required file: 'GUIExecutableFullPath'. The installer might be corrupted . try redownloading or using new media distribution. " does someone know how to fix this?

Message 1 of 9
(5,244 Views)

How did you "remove old software"?  If you used NIPM to remove it (as you would have if you used Windows "Add/Remove Programs and Features"), and "did it correctly" (as has been documented in these Forums and by doing a Web search for "Safely remove LabVIEW"), you should be able to install LabVIEW.

 

If, however, you have used Registry-editing tools to "forceably" remove LabVIEW, the only way I (and others) have found to fix this problem is to backup your system, wipe the hard drive, reinstall Windows and all other installed software, then reinstall LabVIEW.

 

Unfortunately, as LabVIEW has grown in size and complexity, it has become more challenging to install.  Again, suggestions for how to overcome some of these difficulties have been documented here in the Forums and on the Web.

 

Bob Schor

0 Kudos
Message 2 of 9
(5,233 Views)

I have fixed it a long time ago, just had to delete a lot of hidden files. I don't recommend wiping the hard drive that's just lazy advice

0 Kudos
Message 3 of 9
(5,105 Views)

Hi, can you tell me the path of hidden files? I have dame issue. Thank you

0 Kudos
Message 4 of 9
(4,957 Views)

@luca.f wrote:

I have fixed it a long time ago, just had to delete a lot of hidden files. I don't recommend wiping the hard drive that's just lazy advice


Depending on how long "a long time ago" is, that method may "long ago" have expired too. LabVIEW itself is seldom the real problem. That is still fairly contained. But once you start to install DAQmx and many other things that add actual kernel mode drivers, just deleting hidden files will nowadays rather cause your system to blue screen or cause other undesired effects than get your system cleaned.

Rolf Kalbermatter
DEMO, TU Delft
My Blog
0 Kudos
Message 5 of 9
(4,928 Views)

@luca.f wrote:

I have fixed it a long time ago, just had to delete a lot of hidden files. I don't recommend wiping the hard drive that's just lazy advice


It's not lazy advice.  You should read all of Bob's posts regarding installation disasters using NIPM.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 6 of 9
(4,917 Views)

One case I had is the NIPM window (starting already for uninstalling) was cancelled accidentally. You can't not reinstall a new NIPM due to the path error. Try this 

1. run  cmd and run command

C:\Program Files (x86)\National Instruments\Shared\NIUninstaller>uninst.exe /NoNIPM

 

2. if a NI installation window pops up, try to uninstall package manager related items (such asn NI Package manager support, NI Package manager COre). 

 

3. Try to re-install a new NIPM (no reboot needed).  

End

0 Kudos
Message 7 of 9
(3,466 Views)

In 2017, the first year NIPM was introduced, I messed up two perfectly-good PCs running Windows 10 and (if memory serves) happily running LabVIEW 2014, 2015, and 2016.  Here was the method I used to repair both machines:

  1. Backed up my Profile.
  2. Made a list of the installed Software (Office, Browsers, Utilities, settings required to use the local network).
  3. Reformatted the C: drive.
  4. Reinstalled fresh copy of Windows 10.
  5. Configured Windows 10 and "joined the Network".
  6. Installed fresh copies of other Software described in Step 2.
  7. Restored my Profile (Step 1).
  8. You can be very sure that when I (eventually) again downloaded and tried to run NIPM, I was very careful and very cautious.  I do remember the lessons I learned with LabVIEW 2011 (which also needed extensive babying to prevent required NI Services from not installing properly -- in some cases, needing me to install "one feature/driver/toolkit at a time, and in the correct(??) order".

It took me 2-3 days to carry out such a "recovery".  I only did it after spending a week or two trying other "fixes" that seemed to make things go worse.  Your mileage may vary ...

 

Bob Schor

0 Kudos
Message 8 of 9
(3,449 Views)

Another potential solution for a damaged NIPM install is just to install the latest version from ni.com here (new version released a few weeks ago). It's not that you're hoping for NIPM fixing some bug that is causing a problem, but instead that a new NIPM version does a clean install of itself, which can solve numerous problems.

0 Kudos
Message 9 of 9
(3,424 Views)