Showing results for 
Search instead for 
Did you mean: 

I can not lunching Labview2018

Go to solution

OS : win10 64bit,

LabVIEW 2018 : 64bit & 32 bit (not SP1)

I got my new NB, then I installed the LabVIEW 2018.

When I Lunching LabVIEW, I would stuck here,"initializing menus", 32bit & 64bit is the same.


Then I stop the "NI service locator" in windows service, the LabVIEW luncher is running.

If I want to use the "Find Example", I need to open the "NI service locator" again.

I tried to reinstall LabVIEW so many times, but didn't work.

How can I fit it?


0 Kudos
Message 1 of 9

What is a "NB"? Please spell things out.


What is the OS of the computer? Are you running any unusual antivirus or security software? Do you have admin rights? Are all drives local or are some on the network? Did you reboot after installation? ...

0 Kudos
Message 2 of 9

NB is notebook, OS is win10 64bit.

I installed "Symantec" from my company, I have admin rights, And all drivers are local, I tried to reboot many times.


0 Kudos
Message 3 of 9

Have you tried with Symantec disabled? Did you allow LabVIEW to access the network?

0 Kudos
Message 4 of 9

I don't have authority to disable Symantec, and I need to ask the IT dept. about the network. But my colleage's LabVIEW 2018 is fine, the different between us is his OS is win7 64bit.

0 Kudos
Message 5 of 9

A couple of points:

  • LabVIEW 2018 (32-bit, English) installs just fine on a Windows 10 Pro (x64) Laptop running on standard Intel hardware (I'm pretty sure it will run fine on AMD chipsets, but am not so sure about Notebook processors).
  • I've never had to disable Anti-Virus (including Symantec and McAfee) to get installations to work..
  • Before re-installing NI Software, it is important to completely remove all earlier installs.  You do this by going to Programs and Features, finding NI Software (if it is there), doing "Remove All", and rebooting.  Note that you will not be able to remove NI Package Manager at this time.When it seems to be gone, see if NI Package Manager is still there -- if it is, remove it as well, and reboot.
  • Once everything except NIPM is gone from National Instruments Software, go remove NI Package Manager (say "Yes" when it asks "Are you sure?".  Reboot.
  • Check once more for NI Software -- sometimes there are things that are still lurking.  Remove them.
  • If VISA routines are showing in Programs and Features, I usually remove them at this time.
  • Now go to NI Software Downloads and specify that you want to install LabVIEW 2018 (32-bit).  Pay attention to the version of NIPM that gets loaded -- the current version is 19.6 (unless another update has come out recently) -- you don't want versions earlier than 19.5.  I recommend installing "slowly" -- choose only LabVIEW 2018 on the first pass, no Modules, Toolkits, or Drivers.  Take the minimum additional features.
  • On subsequent passes, you can install Modules and Toolkits.  Try to leave Drivers for last (though NIPM will probably install some for you even though you didn't ask for them ...).

Bob Schor

0 Kudos
Message 6 of 9

I actually had Antivirus issues a couple of years ago. I think it was LV2014 SP1 that failed to upgrade when AV was active. I don't remember which AV it was, though.


G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
0 Kudos
Message 7 of 9
Accepted by IanChen5566

@IanChen5566 wrote:

I don't have authority to disable Symantec, and I need to ask the IT dept. about the network.

Over the years, there were quite a few reports of issues with overzealous AV software. As a first step, get IT involved. If they have an iron grip on the computer systems, It could be the antivirus or some other local policies that might prevent certain services to correctly start. If they tie down the system it is their responsibility to get things working.


Is there anything in the system log?

What other software is installed?

As I said, LabVIEW needs network access for internal communications, even if it does not connect to anything external.

Have you tried running LabVIEW as administrator ( as administrator to see if it makes a difference)

Who installed the OS? Was it a clean install from IT? (Sometimes, commercial computers have some extra "value added" questionable security software preinstalled and if your IT just install their stuff over it, things can interact. Who made the computer?)

Message 8 of 9

Thanks, Our IT department find their system block the service!!

Message 9 of 9