Showing results for 
Search instead for 
Did you mean: 

I Need Good Ol' All White Background on Block Diagram.

I've just changed from 2010 to 2012 and find I have alternating white and grey backgrounds nestied on the block diagram. A nice touch except that, at least on my system, boolean wires become all but invisitble when on the grey background. Anyone know how I can default all bd bg color back to all white? I don't want to tool -> paint each one, of course.

0 Kudos
Message 1 of 7

I've never seen other than a white background on the Block Diagram, but I have seen the Front Panel background change.  Try going to Tools, Options, Environment, and look at Colors.  Note you may have to uncheck "Use Default Colors".

0 Kudos
Message 2 of 7

Thanks Bob. I'd never seen other than a white background on BD (definitely not FP) either. It's gray, though the Tools / Options / Environment shows white: #ffffff. This background change didn't happend in 2010 but does, for me, in 2012. I'm playing with a student edition to make fully sure that some lessons work properly, though I doubt that's the problem.


Actually, maybe this is it: The bd I'm testing was created in LV 2010 (not student), and is being opened in 2012 (student). Maybe there's a workaround hidding here, since I can create a new bd in 2012 (student) and it's white, as expected.


Thanks for the settings sanity check Bob -- now I am pretty sure I'm not missing a switch somewhere.

0 Kudos
Message 3 of 7

Hi evan1138


That sounds odd could you add a screenshot of how it looks your block diagram.


Does the block diagram color is different for just one vi or for all the vi’s?


 Have you try to open that same vi in a different computer?



Esteban R.

0 Kudos
Message 4 of 7

Looks like you are showing the grid on the block diagram, possibly with a narrow spacing.


Go to "tools...options...block diagram" and scroll down to the "Block Diagram Grid" entry. Uncheck "[]show block diagram grid"

0 Kudos
Message 5 of 7

Really clever thought! But that's not it. Thanks.

0 Kudos
Message 6 of 7

Here's the screen shot,


But I think I may be really dumb. The first clue is that when I create a new vi the bd is white as expected. Second clue is that I inherited this gray bd code, and it was also the first thing I opened with the 2012 system. So the answer appears to be that the bd background actually is gray, made that way by the original author. Sheesh.


Sorry folks. I swear I spent a couple of hours searching before troubling you good people.


Gray BD

0 Kudos
Message 7 of 7