LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

How to disable wires moving automatically in LV 2021 ?

Hi community,

 

we recently upgraded from LabVIEW 2019 to 2021.

Now when I move bd objects, connected wires sometimes jump unpredictably - and it's really annoying.

Is there a way to disable this feature?

 

Example: when I move the index array node at the bottom of the image below down by 1 pixel with an arrow key the outputs become hard to distinguish on the way to the case structure.

 

before:

FlorianLudwig_0-1633509205338.png

after:

FlorianLudwig_1-1633509274837.png

Additional feedback on the new wiring for NI:

When wiring objects by clicking the start and end point of the wire, resulting wires are less neat than before (wires enter terminals from unexpected directions, gaps to objects are too small,...).

Usually marking the wire and using cleanup improves the wiring. Neat wiring has become more tedious for me.

 

 

Message 1 of 12
(3,416 Views)

Hi Florian,

 

did you disable "Automatic wire routing" in the LabVIEW options?

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
Message 2 of 12
(3,412 Views)

Hi Gerd,

 

thanks for chiming in.

I did, but that didn't fix the issue (days ago, several restarts).

I just reactivated it (because I had not encountered a case this severe before deactivating it) - it seems to make no difference.

I was hoping for a secret ini key or something similar (or that I had overlooked something when scouring the options).

 

I made a stripped down version of my vi to play around with if anybody is interested

 

Best regards

Florian

 

0 Kudos
Message 3 of 12
(3,406 Views)

I filed a Bug Report to NI over this exact same issue a few weeks ago  Unfortunately, I don't think it has drawn much attention.  It seems to be a "feature" ...

 

Bob Schor

Message 4 of 12
(3,376 Views)

Seems like LV 2021 was a step backwards in many respects.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 5 of 12
(3,361 Views)

@Florian.Ludwig wrote:

Hi community,

 

we recently upgraded from LabVIEW 2019 to 2021.

Now when I move bd objects, connected wires sometimes jump unpredictably - and it's really annoying.

Is there a way to disable this feature?

 

Additional feedback on the new wiring for NI:

When wiring objects by clicking the start and end point of the wire, resulting wires are less neat than before (wires enter terminals from unexpected directions, gaps to objects are too small,...).

Usually marking the wire and using cleanup improves the wiring. Neat wiring has become more tedious for me.

 

 


 

 

IKR, the automatic wire routing in LabVIEW 2021 SUCKS SUCKS SUCKS 

 

It creates MORE WORK than it saves just like the automatic block diagram cleanup.

========================
=== Engineer Ambiguously ===
========================
Message 6 of 12
(3,337 Views)

As Aristos said the issue described in the Idea Exchange post is fixed for SP1. If there are other cases you think are different, then report them as well. 

0 Kudos
Message 7 of 12
(3,304 Views)

@GregR wrote:

As Aristos said the issue described in the Idea Exchange post is fixed for SP1. If there are other cases you think are different, then report them as well. 


This is why I usually wait until the SP1 release before I upgrade. 

 

I jumped the gun on LabVIEW2021, some lessons need to be relearned occasionally I guess...

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 8 of 12
(3,299 Views)

LV 2012 --> LV 2012 SP1 comes to mind...

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 9 of 12
(3,270 Views)

This was also documented in the idea exchange where NI confirmed the bug, the intended timeline for the fix, and the workaround of hitting (not holding) the "w" key.

 

Read more details (and similar feedback) here: https://forums.ni.com/t5/LabVIEW-Idea-Exchange/LV2021-Deactivate-Wire-Auto-Routing/idi-p/4183557?pro...

 

Eric Reffett | Director, Product Management | 1.512.683.8165 | ni.com
0 Kudos
Message 10 of 12
(3,106 Views)