LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Help needed with LabVIEW and Raspberry Pi for HTTP Request to Firebase API

Hi everyone,

 

I am seeking your help to solve an issue that I have encountered while using LabVIEW 2022Q3 32bit Professional edition with a Raspberry Pi 3 model B. I am using LINX to deploy the VI on the Raspberry Pi.

When I write a program like blinking a LED, I can run it on my PC, and the LED blinks on the Raspberry Pi GPIO. Furthermore, when I make a real-time application and run it as a startup, it works perfectly fine.

However, I am facing a problem when I put a simple VI with an HTTP request GET from the Firebase API. It works when I run it on the Raspberry Pi, but when I put it as a startup, it does not work. I have been trying to troubleshoot the issue for a while now, but I have not been able to figure it out.

If anyone has any suggestions or has faced a similar issue, please let me know. I would be grateful for any help or advice you can provide.

Thank you.

0 Kudos
Message 1 of 2
(658 Views)

similar issue: labview 21sp1, with raspberry pi 3b,  be fine with GPIO or USB ports, However, when plan to sending/receiving data to/from firebasede, However, I run on raspberry pi, it showed:  ployment with errors when being firebase subVIs in raspberry pi. Does anyone know it? Thanks

0 Kudos
Message 2 of 2
(469 Views)