LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Help making CIN *.lsb file with Visual Studio .NET

Hello,
I am trying to compile/build a simple *.lsb file to use in a CIN vi
using Visual Studio .NET. I setup the project in Visual Studio as
stated in the NI manual and everything seems to work fine, the .lsb
file is made without error. But when I go to load the file in labview,
labview continues to say the file wasn't loaded. So, I am assuming I
must change some setting in the Visual Studio project. I don't have
any idea on what to change though, any ideas?
Thanks,
Tim
0 Kudos
Message 1 of 3
(1,509 Views)
I tried it in several ways. It worked well for the .lsb file compiled
from the upgraded project of VC++ 6.0. However, when I started a new
project in .NET, I got problem. Intead of saying the file wasn't good,
it loaded the .lsb quietly. But the VI was simply not executable. I'm
trying set up the project options. I'll let you know as soon as I got
it. I'm also looking forward to your good news. thanks. GC

timdet@san.rr.com (Tim) wrote in message news:<3629ef86.0204051544.1dc5b71e@posting.google.com>...
> Hello,
> I am trying to compile/build a simple *.lsb file to use in a CIN vi
> using Visual Studio .NET. I setup the project in Visual Studio as
> stated in the NI manual and everything seems to work fine, the .lsb
> file is made without error. But when I go to load
the file in labview,
> labview continues to say the file wasn't loaded. So, I am assuming I
> must change some setting in the Visual Studio project. I don't have
> any idea on what to change though, any ideas?
> Thanks,
> Tim
0 Kudos
Message 2 of 3
(1,509 Views)
Hello,
Well I finally got it to work. In my case at least, I needed to
change a setting in the properties page under Linker\Input\Module
Definition File" to "\win32\lvsbmain.def".
I think that is the only deviation from the manual that I had to do.

Tim

huer@yahoo.com (gxchem) wrote in message news:...
> I tried it in several ways. It worked well for the .lsb file compiled
> from the upgraded project of VC++ 6.0. However, when I started a new
> project in .NET, I got problem. Intead of saying the file wasn't good,
> it loaded the .lsb quietly. But the VI was simply not executable. I'm
> trying set up the project options. I'll let you know as soon as I got
> it. I'm also looking forward to your g
ood news. thanks. GC
>
> timdet@san.rr.com (Tim) wrote in message news:<3629ef86.0204051544.1dc5b71e@posting.google.com>...
> > Hello,
> > I am trying to compile/build a simple *.lsb file to use in a CIN vi
> > using Visual Studio .NET. I setup the project in Visual Studio as
> > stated in the NI manual and everything seems to work fine, the .lsb
> > file is made without error. But when I go to load the file in labview,
> > labview continues to say the file wasn't loaded. So, I am assuming I
> > must change some setting in the Visual Studio project. I don't have
> > any idea on what to change though, any ideas?
> > Thanks,
> > Tim
0 Kudos
Message 3 of 3
(1,509 Views)