LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Getting transparent name labels on LV8 block diagrams.

In LV8.0, why doesn't checking the "Use transparent name labels" box on the Block Diagram Options page have any effect? In LV7.1, for example, checking that box allows for name labels that have no surrounding color or outline.
0 Kudos
Message 1 of 13
(2,867 Views)

It seems to work as expected. To test this I

1. Make sure that Options -> Block Diagram -> Use transparent name labels is unchecked (off)

2. Go to your front panel and drop a new control

3. Goto the block diagram and check the label for the control has a border and is not transparent.

4. Make sure that Options -> Block Diagram -> Use transparent name labels is checked (on).

5. Go to your front panel and drop a second new control.

6. Goto the block diagram and check the label for the second control does not have a border and is transparent.

David

Message 2 of 13
(2,857 Views)
What you say is true, David. Curiously, however, under LV8 the check box on the BD Options page has no influence on free text written on the BD (entered using the "Edit Text" tool). Whereas under LV7.1, the check box controls the appearance of free text in the same way it controls the appearance of Control Name Labels.

What I'm looking for is a way (under LV8) to put free text on the BD that does not have a surrounding box. Apparently the check box on the BD Options page is not the way. Perhaps there's an INI file parameter that does this?

- Howie
0 Kudos
Message 3 of 13
(2,837 Views)

Christina Rogers of NI R&D said

transparentBDFreeLabels=True

may work in LV 8.20.

She was not sure about LV 8.0

See LAVA thread here.

http://forums.lavag.org/index.php?showtopic=3866&pid=18546&st=0&#entry18546

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 4 of 13
(2,818 Views)
The suggestion to use: transparentBDFreeLabels=True in the INI file doesn't appear to work in LV8.0. 😞
- Howie
0 Kudos
Message 5 of 13
(2,806 Views)

Update to that thread.

try

transparentBDLabels=True

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 6 of 13
(2,783 Views)
Ben, Your suggestion to try "transparentBDLabels=True" instead of "transparentBDFreeLabels=True" in the LV8.0 INI file didn't work either. 😞
- Howie
0 Kudos
Message 7 of 13
(2,759 Views)
A workaround is to type in the comment, choose the Transparent font color for background, and paint the comment box.  Then copy and paste it where needed and change the text.
- tbob

Inventor of the WORM Global
0 Kudos
Message 8 of 13
(2,747 Views)
tbob,Your suggestion:

"A workaround is to type in the comment, choose the Transparent font color for background, and paint the comment box. Then copy and paste it where needed and change the text."

. . . is only a partial fix. It doesn't eliminate the surronding box (i.e. outline). Any other ideas?

- Howie
0 Kudos
Message 9 of 13
(2,741 Views)
It got rid of the box for me?

Just did the ol' <ctrl><shift><right-click>, picked the paintbrush tool, then right clicked on the box to bring up the colour palette, and picked transparent.

LV 8.2
0 Kudos
Message 10 of 13
(2,738 Views)