LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Fix LabVIEW Code generation failed to execute

Solved!
Go to solution

I'm using LabVIEW 2011. I try to use DAQmx assistance to generate one pulse signal from my USB 6259. LabVIEW popped out an error message "LabVIEW Code Generation failed to execute"

I try to reinstall LabVIEW 2011, but the error is still there. Please help

0 Kudos
Message 1 of 10
(4,093 Views)

Try repairing NI DAQ.  The driver may have gotten corrupted.    


"Should be" isn't "Is" -Jay
0 Kudos
Message 2 of 10
(4,083 Views)

I re-install DAQmx. but the problem is still there.

0 Kudos
Message 3 of 10
(4,073 Views)

Hello JimSI,

 

Did you follow the next steps?

 

  1. Remove LabVIEW 2011 and NI-DAQmx from your computer
  2. Install LabVIEW 2011
  3. Install NI-DAQmx 9.6.1

 

Regards,

0 Kudos
Message 4 of 10
(4,052 Views)
Solution
Accepted by topic author JimSi

Problem is gone after re-install LabViEW and DAQmx.

thanks

 

0 Kudos
Message 5 of 10
(4,034 Views)

Hi All: 

 

Same problem here.

 

LabVIEW 2012 64-bit

NI MAX 5.5

 

Failed to execute LabVIEW Code Generation after configuring Express VI for Data Acquisition.

 

Academic Site License... IT has installed over network.

 

I'm guessing the fix a wipe and reinstall?

 

Thanks! 

0 Kudos
Message 6 of 10
(3,884 Views)

Hi williamlweaver,

 

You can try the steps above or you could try force reinstalling over your current installs.  Make sure to force reinstall LabVIEW before you force reinstall DAQmx.  Here is a Knowledgebase article on force reinstallation of our products;

 

http://digital.ni.com/public.nsf/allkb/ADD22E807D5A12AD862579EC00760F79?OpenDocument

Peter T
Applications Engineer
National Instruments
0 Kudos
Message 7 of 10
(3,858 Views)

Thanks, Peter T!

 

I will give it a go with our IT department and report back here.

 

We've been using LabVIEW in our teaching labs since 2000 and this is the first time we've run into the problem.

 

Thanks for the quick reply,

 

-Bill  =]

0 Kudos
Message 8 of 10
(3,849 Views)

I have been getting exactly this problem with the 'LabVIEW code generation failed' message, but with LabVIEW 2017 and DAQ 19.6.  Allowing for this being an old thread, does anyone have a better solution to the DAQ problem than the drastic, uninstall and reinstall everything option? 

 

   Regards,

 

         Ian

0 Kudos
Message 9 of 10
(1,910 Views)

FYI, I got the same problem as you with LabVIEW 2020 and Max 20.5.  All I do is use the "repair" option in "Programs & Features" instead of uninstalling the whole NI package.  It fixed.

0 Kudos
Message 10 of 10
(647 Views)