Showing results for 
Search instead for 
Did you mean: 

FPGA VI is broken when Robotics Starter Kit example is copied.

Go to solution
I'm using LV 2010 and I'm playing with the Robotics Starter Kit "Roaming" example. When I open the Starter Kit project directly from the "Example Finder" and look at the FPGA code, all is well. However, when I make my own copy of the project (By performing a Save As, and selecting Duplicate .lvproj and Contents), there is a problem with the FPGA code. If I open "Starter Kit FPGA" I get a broken arrow. Some of the FPGA IO references don't seem fully defined. See attached screen grab. I also notice that the reference to the FPGA Bit (in still points to the original location of the bitfile in LabVIEW 2010/examples, instead of following the new copy of the project. Can anyone tell me why this is happening and/or how to fix it so that I can modify/ rebuild the FPGA image. Note: I also have LV2009 installed, and I'm sure I was able to do this in the past.
Get a life? This IS my life!
0 Kudos
Message 1 of 8

Sorry.  Here is screen grab or error and broken VI.



Get a life? This IS my life!
0 Kudos
Message 2 of 8
Accepted by topic author Philbot

Problem Solved.... sort of.


Don't know why the Save As didn't work, but it would appear that the "Correct " way to get a working copy of the Starter Kit "Roming" app is to use the New "Probotics Project" option from the LV Getting Started screen.


This is made more obvious from the "LabVIEW 2010 Robotics" portal, but it's also available from the standard "LabVIEW 2010" portal if you dig into the "New Project" choices.


ps: "Portal" is probably not the correct term, but I don't know what to call the different "flavors" of LabVIEW.





Get a life? This IS my life!
0 Kudos
Message 3 of 8



I'll look into what might be causing the problem when using "save as...".  In addition to using the project wizard to copy the project, you can simply copy the entire folder: "<LabVIEW 2010>\examples\robotics\Starter Kit\" to a new location, then open the project inside the copied folder.


Chris M

0 Kudos
Message 4 of 8



I haven't been able to reproduce the problem you are seeing with the broken FPGA VI.  I tried copying the Roaming project using the Duplicated option, and none of the VIs in the copied project end up broken (I am using LabVIEW 2010 f2).  Can you list the exact steps you are taking to reproduce this problem?


I am seeing the problem where the FPGA reference still points to the original bitfile, even after the project has been copied.  This problem has been reported in CAR 243460.


Chris M

0 Kudos
Message 5 of 8



Hmmm.  That is odd.


1) Open LabVIEW 2010 from desktop Icon

2) Click Find Examples

3) Select Robotics / Starter Kit / Starter Kit Roaming Project


  Open FPGA VI to verify no errors....  OK


4) From project Explorer window...Select Save As / Duplicate/ Include all dependancies.

       Choose /My Documents/Labview Data  as destination folder.

5) Close current project. (Save All)


6) Open newly created project:

    My Documents\LabVIEW Data\examples\robotics\Starter Kit\Starter Kit Roaming\Starter Kit Roaming.lvproj

    No problems are indicated during load


  Open FPGA VI to verify no errors....  Now have errors.


  What is confusuing is that only SOME of the IO references cause trouble.. eg: FPGA LED is OK.



Get a life? This IS my life!
0 Kudos
Message 6 of 8

Hi Phil,


I am still unable to get a broken FPGA VI when I follow the steps you listed.  I've tried it on two different machines with the same results.  Do you see the same problem when you manually copy the "<LabVIEW 2010>\examples\robotics\Starter Kit\" folder?  Have you seen this on multiple computers?


Chris M

0 Kudos
Message 7 of 8

It wouldn't be the first time my PC was the root cause. 


It's possible that some components are not fully installed.


This is not my normal dev machine.  I haven't tried elsewhere.

I wouldn't dwell too much more on it at this point.  If I get a chance I will verify elswhere.


Thanks for the perserverance.



Get a life? This IS my life!
0 Kudos
Message 8 of 8