LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Error 56 - Labview TCP interaction with Cognex help

Solved!
Go to solution

VI attached. Using Labview 2022 Q3. 

 

Trying to open a TCP connection with a Cognex InSight 7802 camera. 

The VI has an error 56 (source TCP Read)  which happens after I try and send the admin login. 

 

Flow order - TCP open connection --> TCP Read, CRLF, 100 bytes (this outputs Welcome to InSight 7802 Session 0) --> TCP Read, 6 bytes (This outputs User:) --> TCP Write, attempting to input admin\r\n --> TCP read, 10 bytes (Error 56). If it was performed properly, the below should be output. 

JOECAMM_0-1707215063344.png

 

I've tried varying byte amount, varying the order etc but am stumped! 

Feels like it isn't sending the 'admin' command or something.

 

Any help would be greatly appreciated. 

 

0 Kudos
Message 1 of 4
(344 Views)

Is that screen shot from a Telnet or SSH session? Telnet or SSH is NOT raw TCP/IP but has some more or less complex signaling (SSH also has transport encryption!)

Rolf Kalbermatter
My Blog
0 Kudos
Message 2 of 4
(301 Views)
Solution
Accepted by topic author JOECAMM

 

Your error is in string constant! You cannot write \r\ln in a normal string constant. You have to activate code display!

 

Walker34_0-1707307236751.png

 

0 Kudos
Message 3 of 4
(279 Views)

Thanks a lot - worked immediately! 

0 Kudos
Message 4 of 4
(208 Views)