Showing results for 
Search instead for 
Did you mean: 

Error -20080 quadratic programming

 I tried to to the qp vi that is present in mathematics/optimization toolkit in LV8. The same inputs (matrices) are given to matlab script node and quadprog command is used. It is running fine.  I tried qp vi and gave the inputs accordingly. It is showing

Error -20080

 Time increment must be greater than the (window length)/16

please help I m not getting what the error is.

I want to download this vi into fieldpoint. As it not allowing to download the script node i must use qp vi.

0 Kudos
Message 1 of 15


There are several robust QP solvers in TOMVIEW that you can try out - QPOPT, CPLEX ans so on.

Best wishes, Marcus

Marcus M. Edvall
Tomlab Optimization Inc.
855 Beech St #121
San Diego, CA 92101-2886

e-mail: medREMvall@tomREMopt.coREMm
Office1: (619) 203-2037
Office2: (619) 595-0472
Fax: (619) 245-2476
0 Kudos
Message 2 of 15
I want to know why iam getting that error?. how to get rid of that error using that vi?

Message Edited by sainath on 02-23-2007 02:16 AM

0 Kudos
Message 3 of 15

I am not familiar with the mathematics and optimization toolkit in LabVIEW.  Here is the list of toolkits that NI provides:

Any of these that you are talking about?


Applications Engineering
National Instruments
0 Kudos
Message 4 of 15
May be a problem finding an initial feasible solution.  Can you post the code that is giving you problem so that we can take a look?

0 Kudos
Message 5 of 15
Hi Jim,
       I have attached my program


Message Edited by sainath on 02-26-2007 02:20 AM

0 Kudos
Message 6 of 15
Had some problems with some missing subVIs.  Can you create a quick wrapper for the QP call and save with the default data that reproduces your error?  In other words, highlight the qp VI, and from the edit menu choose create subVI.  This will create a simple wrapper.  Open the wrapper VI, and then run your application until you see the error.  Now go to the wrapper and from the edit menu choose make current values default, and then save the VI.  That should be sufficient for me to reproduce the error without needing your subVIs.

0 Kudos
Message 7 of 15


As Jim mentionned, it will be easier for us to help you if you could isolate the problem. Please let us know if there is anything else we can help you with throughout the process.


Rudi N.

0 Kudos
Message 8 of 15
Hi jim and Rudi,
        sorry for the delay. This time i have attached the wrapper file with the default data that was giving me the error. (Actually with QP vi it is not running even for one iteration.)
0 Kudos
Message 9 of 15

The problem is in the mapping you have made from "quadprog" to Quadratic  You are passing your inequality constraints into Quadratic as equality constraints.  For this set of constraints (as equality constraints) there is no feasible solution.  Simple inspection of the constraints shows this.  Quadratic requires that the inequality constraints have both an upper and a lower bound (InEqu_lowBound <= Dx <= InEqu_uppBound), but you can use +/-Inf in the bounds arrays.  Attached is a modified version of the warpper that shows the mapping. 

Message 10 of 15