Showing results for 
Search instead for 
Did you mean: 

Error 1003 occurred at Invoke node in VI (Post build)

Go to solution


I have an application that when the user click on a button call another VI and displayed some data, I have been getting 1003 Error (Error 1003 occurred at invoke node in VI) This only happens after I build the .exe, I don't get this error while on the labview environment. Any ideas why this happens?  

I tried to attached as much information as I can to help understanding my problem.

The screenshot "ViCall" - is the main Vi when one of the buttons is clicked call the other VI

the screenshot "VICalled" - is the one that open when the button is clicked and displayed data.

The screenshot "Error1003" - is what I get after I build the application (if I run within labview I don't get that error)

The Screenshot "AppBuild" - this is how I build the .exe (It might help to give clues where my problem is which I can only assume it must be on this part).


I would appreciate if anyone could give me an advice of where the problem is, thanks!

Download All
0 Kudos
Message 1 of 3
Accepted by topic author dreamheart

The filepath to your dynamically called subVIs are incorrect when used inside an executable. As you added these to your build these VIs now reside inside your executable, the calling path then is "directory of exe"/"filename of exe"/"vi-path & name inside exe".


Regards, Jens

Kudos are welcome...
Message 2 of 3

Thanks Jg69, I'm very new to labView and programming itself, I cant believe I didn't realize something as simple as that hahaha. I appreciate the help, happy Halloween 🙂

0 Kudos
Message 3 of 3