Showing results for 
Search instead for 
Did you mean: 

Empty task out from DAQmx Create Virtual Channel (VI)



I'm using a NI USB_6008 in my project and I use ao0 to provide my device with supply-voltage. And I use ai1 to measure voltage on my device. The thing is that I have been using another identical USB_6008 before, and everything worked just fine, but now when I want to use this new DAQ, it doesn't work at all and I get "empty" or "unnamed" task out. I have the right serial-number and device-number in my hardware initiation. And I have used the test panel in    "Measurement & Automation Explorer to check that the channels works properly. I have also changed the USB-port and also updated my drives. But nothing has helped. 


Unfortunately I can not send the code here since it's too big and complicated but I'll attach a screen-shot of the part the I'm stucked in with the "probe" values. 


I'll really appreciate it if someone could explain for me why I get "unnamedTask". 




0 Kudos
Message 1 of 3



I was wondering if you were able to resolve this issue.   I'm encountering the same problem.  I run the VI as part of a TestStand Sequence file.  First pass the VI runs without issue, however, all subsequent passes fail due to "Unnamed Task."   Were you able to come up with a solution?



0 Kudos
Message 2 of 3

Just came across this while looking for something else.


Your tasks are unnamed because you haven't named them Smiley Wink.  You can name your task when you call DAQmx Create


Context Help_2013-08-09_15-10-15.png


In the case of the first VI, the task is being implicitly created when the channel is created, so an "unnamed" task is the result.



Best Regards,

John Passiak
0 Kudos
Message 3 of 3