LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Digital filter design Toolkit error(bug) - When build DFD FPAG Code.

Dear all,

 

When I used the DFD toolkit to create the FPGA code automatically, I got the error message " No valid FPGA target is installed".

(You can find the attached picture.)

I have already installed the related software and driver.

(LabVIEW 2020sp1; CompactRIO 20.5; LabVIEW 2020 toolkit (RT, FPGA, DFD)

 

It seems like a bug. 

When I used the LabVIEW 2017, everything is very well. maybe some FPGA target is out of service in labview2020   Capture.JPG

0 Kudos
Message 1 of 7
(250 Views)

Hi,

Do you mind letting me know which LabVIEW version you're using, the 32 bit or the 64 bit one?
I'm asking because the 64 bit version doesn't support a Real Time Module, as stated in the following KB.

What Software Do I Need to Program My cRIO? - NI

Let me know, so we can see what the next step could be.

Cheers

0 Kudos
Message 2 of 7
(206 Views)

Hi,

thanks your reply.

I am using labview 2020sp1 32bit.

And I have reinstalled the toolkits and driver. The error is still there.

 

B.R

0 Kudos
Message 3 of 7
(200 Views)

Great. 
Are the toolkits and drivers all the 32 bit versions?

Also, in LabVIEW 2020, sometimes this issue could occur because the DFD toolkit was installed before the FPGA and RT modules. Can you please confirm that you installed the RT and FPGA modules before the DFD toolkit?

One more thing: could you please let me know what cRIO you are using?

Thanks

0 Kudos
Message 4 of 7
(196 Views)

Hi,

I am using crio-9041. 
Some information:

1, when I using IP generation in a project, I can get the FPGA code automatically. Maybe it means the driver and software version is not a problem. But when I try to use the VI (in the toolkit)to generate the FPGA code,I got the error.

2. When using the labview 2017, it will create a project with crio-9081 default. If I copy the project to labview 2020, it will show a waring triangle. But the vi and fifo can works very well. 

thanks.

0 Kudos
Message 5 of 7
(190 Views)

Good. Thanks for giving me all this info. I'm gonna try to replicate your issue on my side and see where the problem is coming from.
I'll get back to you soon.

0 Kudos
Message 6 of 7
(186 Views)

Hi,

   Do you have any update? Thanks

0 Kudos
Message 7 of 7
(45 Views)