LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQ970A does not show in NI MAX, but it is shown in Keysight Connection Expert

Solved!
Go to solution

I have the following issue:

Turns out i do not see the usb instrument device DAQ970A from Keysight in my NI MAX. I can interact with this instrument through Keysight Connection Expert. 

 

The Instrument appears in "USB Test and Measurement Devices".

I already tried in device manager selecting the IVI Drivers.

 

I can seem to find the solution for this problem.

I need to use this instrument with usb interface in labview.

 

 

0 Kudos
Message 1 of 5
(115 Views)

You will need labview device drivers for interacting with the device which is available from below link.

https://www.keysight.com/in/en/lib/software-detail/driver/daq970-labview-driver-for-the-keysight-dat...

 

 

 


CLD Using LabVIEW since 2013
0 Kudos
Message 2 of 5
(89 Views)

I installed the labview keysight drivers for communicating and device still does not show up in NI MAX 

ni max device not showing.PNG

It is still shown in Keysight connection expert as following:

connection expert keysight daq970a.PNG

 

And in my device manager it also is displayed as USB Test and Measurement Device (IVI)

device manager device.PNG

and in my labview program i can access to device's function palette:

j_ortiz97_0-1637273070397.png

but i cannot access the instrument through the constant, it just does not show up.

0 Kudos
Message 3 of 5
(59 Views)
Solution
Accepted by topic author JorgeOrtiz97

From Measurement and Automation explorer go to Tools and select Reset Configuration Data.

Then restart the system and then check in Measurement and Automation explorer


CLD Using LabVIEW since 2013
0 Kudos
Message 4 of 5
(51 Views)

I was able to solve it, it turns out i just needed to turn off the daq's file access off (which i had it on) in the user settings. Thanks, this issue is solved.

0 Kudos
Message 5 of 5
(31 Views)