LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Custom excel template path in Stanalone application

Solved!
Go to solution

Hi All,

 

I have a problem in building application that includes Report Generation Toolkit.

So, I use Ms Office report express.VI which has custom excel template path is defined in this VI

The problem is when I build the application, The VI can't seem to connect to path of the template in the target PC.

 

Note : I have added the template, NI_Excel.lvclass, _Excel Dynamic VIs.vi, NI_Report Generation Toolkit.lvlib to the project file and set as always included.

 

The application runs without any error. but the Excel report is not generated.

 

Any help is highly appreciated 😄

 

It's really driving me nuts now

0 Kudos
Message 1 of 16
(3,194 Views)

Did you add the Report Generation VIs to your project and include them in your application?

 

Including Report Generation VIs in Stand-Alone Applications (Report Generation Toolkit)

 

 

 


Now is the right time to use %^<%Y-%m-%dT%H:%M:%S%3uZ>T
If you don't hate time zones, you're not a real programmer.

"You are what you don't automate"
Inplaceness is synonymous with insidiousness

0 Kudos
Message 2 of 16
(3,190 Views)

Hi PhillipBrooks,

Yes, I did ! does it have anything to do with relative path/absolute path ?

I'm sorry...really new in LabVIEW 🙂

 

 

0 Kudos
Message 3 of 16
(3,185 Views)

I believe the toolkit uses ActiveX to open and manipulate the template. 

 

Does your target PC have MS Office installed?


Now is the right time to use %^<%Y-%m-%dT%H:%M:%S%3uZ>T
If you don't hate time zones, you're not a real programmer.

"You are what you don't automate"
Inplaceness is synonymous with insidiousness

0 Kudos
Message 4 of 16
(3,178 Views)

Yup, the target PC has MS office and activeX installed 😄

Perhaps to give you clearer view of the problem, here i attach my configuration for the build

source files.JPG

 

 

And this is how the excel template file accessed in MS Office Report Express.VI

template source.JPG

0 Kudos
Message 5 of 16
(3,171 Views)

The application builder should put your template that you noted as "Always Included" in the "\data" sub-folder. Is it there?

0 Kudos
Message 6 of 16
(3,167 Views)

Yup, It's there!


the application is actually running in target PC without error.


But, It doesn't generate the output file from the MS Office report express.VI

 

Do you think it's because I wired "path to save report" as control??

path.JPG

0 Kudos
Message 7 of 16
(3,164 Views)

If it's an empty path, yes, and you'd never know it because, from your diagram, you're not handling the error output of the express VI.

 

If your path is fixed, put a constant, otherwise, find an appropriate way to populate the control at run-time, e.g., read from file, prompt the user, etc.


Then wire the error input to the express VI and pass the error output to an appropriate error handling routine or on to the next function in your data path.

0 Kudos
Message 8 of 16
(3,161 Views)

The path is actually defined. and this time I have put error handler to Ms Office report .VI

 

and I got this error

error.JPG

 

Btw, Would you mind to list the steps that I have to do to make the application that has custom excel template and "path to save report" control? or simple VI that explain this will be wonderful

It seems like I'm missing something.

 

Thank you so much in advance 😄

 

0 Kudos
Message 9 of 16
(3,159 Views)

That error is indicating that there is something wrong with a value in your "Data" column.

0 Kudos
Message 10 of 16
(3,149 Views)