Showing results for 
Search instead for 
Did you mean: 

Create New FPGA project: cannot find NI-9145 as target

Go to solution



I am using a PXI-1078 together with a NI-9145 EtherCAT Expansion Chassis. In order to develop a FPGA I tried to create a new project with the "LabVIEW FPGA Project" template. However, the NI-9145 chassis is not vibisle under the "Select project type" menu?

Do I have to discover it separately somehow?LLS_0.PNGLLS_1.PNG


Thanks alot


0 Kudos
Message 1 of 8

Thanks for the reply, but this link refers to CompactRio devices. The NI-9145 however is an EtherCAT Expansion Chassis and does not feature an integrared controller, just an FPGA chip. This Chassis cannot be found in the FPGA project template.


Best regards, Lysandros

0 Kudos
Message 3 of 8

So how have you connected the EtherCAT chassis to the PXI ? 

As that chassis is a EtherCAT slave, you need a EtherCAT master to talk to it  through this master.

Is the PXI the EtherCAT master? 

0 Kudos
Message 4 of 8


Yes, I have connected the PXI to the EtherCAT chassis and the EtherCAT chassis to a AKD-Servo drive. The setup works very well and I can communicate to the drive and to the I/Os. But now I want to implement an FPGA as well.

I am not sure whos is the EtherCAT master. In my project tree, both the NI-9145 chassis and the AKD motor are in the same level (see picture below:)




Best wishes,


0 Kudos
Message 5 of 8

Perfect, so you have added the EtherCAT chassis to your project. 

And the PXI is the EtherCAT master in your project. 


Now, on the 9145 chassis, right-click and select New»FPGA Target to create a new FPGA target under the NI 9144/9145 item.

Now you can program the FPGA on the chassis. 


A guide can be found here:

Message 6 of 8

Ok, so I followed these steps and indeed I can create a FPGA VI under the FPGA Target. However, I still get the message



although I do not use any interactive front panels at all. Do I have to somehow configure the NI-9145?

Here is the project tree:



Best regards,


0 Kudos
Message 7 of 8
Accepted by topic author Lysandros

Interactive is when you press the run button on the vi. 

You need to compile the FPGA code and download the bit file to be able to run the code. 

You then don't have a front panel to see the code runnning.  

Message 8 of 8